Few head scratches with condensing

I have factory settings for condensing.
(1)
In this example (2 oboes):


What is causing the “a 2” player label to appear again and again? My instinct tells me it is the rest in between notes, but this is totally unnecessary, at least in this case. Is there an option where I can specify the amount of rests needed for a label to reminded? Or how can I have these two extra “a 2” go away?
In the previous page, 2 bassoons, this doesn’t happen…

(2)
Two horns here, but repeats throughout:


I have the Notation Option set to show rests and hide labels so… why do I see labels? :slight_smile: —from what I saw in the Options everything should be as I like it to be, but then it doesn’t work out in practice.
Besides, it’s a pity that moving the label in Engrave Mode doesn’t trigger a staff respecting for the two adjacent staves (pointing this out because there are some actions that do this in Engrave Mode as well).
It would also be nice if the Flip command worked with player labels.

(3) —added afterwards, sorry.
I would like the player label to appear parenthesised in new pages when there is no change in condensing from before. Is this possible natively or can one do it only by customising the player label text property?

I think that’s it for now.
Any advice is more than appreciated!

Again - and especially for condensing issues - it is best to upload the relevant portion of the project for examination.

(It’s likely to be something to do with a Manual Condensing Change)

IIRC there have been a number of discussions on this topic.

There sure has

So, fine, I have browsed the several topics on the “multiple a2” issue, which I hope gets some kind of internal solution sooner than later. This is what I’ve learned from that:

  1. some instruments show the issue and others don’t even if they have the exact same content (in my example, oboes have the issue and bassoons, with the same rhythm, do not)
  2. there is suggestion to turn off mid-phrase unison, but this is not what I want, since it would create double stems.
  3. having tons (hundreds?) of condensing changes seems to be the panacea of most evils

This project is just at its start, and there has been no condensing change whatsoever.
I have a copyright problem with this project, and if I delete notes the purpose of the post will go away.
I think I will go forward and copy the whole material and then take care about condensing and other things.

Any idea on issue n° 2 that I’ve posted above? Why is the “2.” label appearing if the notation option is set to show rests and hide labels? If I switch to the other one (hide rests and show labels) it works fine.
Is there something triggering this? For context, this is the entrance of the horns, so nothing (just bar rests) before that at all.

You’re welcome to cut it down (e.g. remove other instruments, remove as many bars as you can…) and PM me.

If you find that removing music before or after the troublesome areas changes things then there is likely a sensible explanation for the behaviour.

1 Like

I believe one factor that can result in more “a2” labels than usual is when manual condensing or condensing changes are involved. Dorico generally doesn’t label to excess when it’s just using the Notation Options for condensing and the groups set up in Layout Options.

Do I recall correctly that Daniel has said that looking for a solution to this is already on the Team’s roadmap (although of course no time frame has been promised)?

Tagging @DanielMuzMurray as well.
Here is my condensing symphony excerpt!
Condensing extravaganza.dorico (1.5 MB)

If it doesn’t already open that way, I suggest you keep two tabs, both in full score, one in galley and one in page view.
I have added comments wherever I need assistance. You may want to answer to the comments and upload the project again.

I’ve also watched again John’s 1h-long session on Condensing and I believe what is setting me off-track is that the whole Dorico approach taught to us since forever is to find defaults that work and then change as little as possible.
In Condensing, instead, it is a micromanagement work to be done at the last moment via a huge number of local condensing changes. Is that correct?
No problem with it being such, but it is very time consuming as soon as it is not exactly right at first.

  1. It is the “sim.” playing technique in each Oboe that is causing the multiple a2 indications. You have the sim. technique lasting for the three 3/4 bars whereas in the Bassoons it is only notated at the one rhythmic position. Delete them and re-enter at a single rhythmic position.

For the empty trumpet stave that you mentioned in your Comments, select this option in Condensing for players inactive for the whole system:

1 Like

Have you tried this yourself? It is not changing anything for me.
This is with the “sim.” removed (still a bunch of needless “a 2”:

And this is when I select the first note of each oboe and then add the PT (still the same):

My current setting is “Pair with active player” and either of the other two options look so bad that it is useless, honestly.
From your (and other’s) experience with condensing orchestral scores, is it to be expected that you have to use condensing changes so much?

I do get different results if I follow Daniel’s instructions here:

You’ll always get a repeated a2 marking at the start of a system, regardless of settings, I’m afraid.

Re the Trumpets, the first entry determines how the staves will be used before the first entry. It’s your use of "sim. " that Dorico doesn’t semantically understand - it doesn’t know that you mean “the same articulation as used in the previous bar, and the same articulation that happens to be used by the instrument above/below, so despite the fact this instrument doesn’t have any articulation markings you can condense it with the instrument above that does have articulation markings on every note”.

I believe the version I provided was missing a detail: both oboe have a “cresc.” from the 2nd beat of b10 to the end of b13. If I remove that, the extra “a 2” go away. Thinking of it as a rhythmical problem, I tried to input them again, but the “a 2” come back. The “sim.” PT has nothing to do with this, sadly. I so wished you were right…
Now, how can I solve this? The cresc. is obviously needed…

EDIT: I now got it!
Since the “cresc.” is going up to the end of 13, where the two oboes diverge, it feels the need to specify the a2 before at every time. If I shorten the “cresc.” the extra “a 2” go away, but then I will get wrong playback. I could add an extra “cresc.” but then I would need to hide it from view.
I believe Dorico should be smarter than this for dynamics, and I hope it will become.

Since I have “condense playing techniques whenever possible” in Notation Options, if “sim.” was a problem I should get two of them, instead I do not.

I see, thank you for this.

Regarding the “sim.” thing, is using a PT for this the most commonly accepted way of achieving this or should it be done in some other way that Dorico likes most (man, it sounds like I’m talking about some political arrangement were my tone and speech will determine my fate…).

Do you know why I get bar rests + player labels when the relevant notation option says I should get only bar rests? This causes troubles in the vertical staff spacing.

I just enter it as default text.

In Engrave mode, select the first beat of bar 13 (i.e. where the Oboe split) and add a Condensing Change for the Oboes (ticking the box next to Oboes should be sufficient):

It isn’t that the sim. in each Oboe don’t match (then you would see two sim.) but that they are spanning multiple rhythmic positions.

I think the problem is that both the sim. and the cresc. were spanning over the rest in bar 12, which would normally be where Dorico needs to change the condensing (as the Oboe split at bar 12 and Dorico calculates condensing between rests). This overlap might be confusing Dorico about what to do, resulting in all the a2.

By resetting the Condensing as I described above, you are telling Dorico exactly where you want the Condensing to be recalculated.

Indeed it was the “cresc.”, and I was trying to see what happens with default behaviour.
I will now proceed to input all notes of the first movement of this symphony, then:

  1. casting off
  2. condensing changes system by system as necessary
  3. check that everything is good

Does it sound like a good approach?
Is it the goal to get as close as possible with Notation/Layout options + initial custom condensing groups and then use Condensing Changes whenever needed?