FFFFFF Played P

image

Hey Guys,

As the title and the image suggests. The dynamics are not being played as written, which got me to believe that there are some parameters and CC data that got imported with the .xml file. Does anyone know how to find those parameters and remove them because it occurs throughout the piece…

(The FFFFF is exaggerated for the purpose of the example! :sweat_smile:)

Thanks, Nicolas.

(I’m afraid I have no experience importing XML files, so my helpfulness is limited.) Have you checked the piano roll (Play mode) for any dynamic (or other MIDI controller) data?

Yes, but I didn’t go through all the CC dara for obvious reasons, but i wanted to see if there is a way to see what controllers have data to remove them.

I don’t know of any other way than scrolling, but, again, working with XMLs in Dorico is “above my pay grade.”

Two last thoughts:
Have you checked that the ƒƒƒƒƒ is attached to the downbeat ♩?
Have you tried deleting the dynamic and re-entering it (Shift-D)?

Hope you find a solution soon.

1 Like

Yes, i tried even deleting the notes and re-entering them. Thanks @judddanby

Try selecting all notes and choosing Reset Playback Overrides.

1 Like

as no-one had suggested first trying “reset playback overrides”, I was about to do so. But I see Dan beat me to it…

Also I would go to the “play” menu item, select “automation” and then “Delete all automation”

5 Likes

yes – and on that it would be great if you know which CC(s) may be causing the problem to be able to remove the automation for specific lanes. The trouble with the global approach (though I suspect it’s what’s needed here) is that one might be well down the road of editing a work and have added a number of automation edits elsewhere before noticing the problem which one wouldn’t want to lose.

Thanks @dan_kreider @dko22 @gdball @judddanby for the suggestions but it’s still not budging… I’m using Noteperformer and the BBCSO Pro/Core NPPE. Might be an issue with @noteperformer Because I really don’t see why it would playback lower when i make it PPPPP and stay the same after MF…

OK – as I (and a number of others) have the BBC Core NPPE, I should be able to test this directly if you just attach the project or the relevant section. One obvious thing to check is that you have applied the NP playback template?

Thanks @dko22 Thats the Test Project I made zooming in on the part with the issue.
Test Project.dorico (902.9 KB)

Yes all works well otherwise it wouldn’t sound through NP at all.

Thanks again!

OK – that’s interesting. The first two staccato notes are not rendered loud enough when using NPPE as you say. That’s even the case if you move them say to the second beat in the following bar so there’s a clear gap from the p. However the staccato notes in the following bar are at the correct dynamic. The same is the case if I use NPPE with Cinematic Studio as a comparison. However I notice you you have quite significantly changed the Playback Options defaults from the NP standard for some reason and I find reapplying the default NotePerformer Playback Template does help somewhat.

On the other hand, native NotePerfomer works fine as does the BBC Core used without NotePerformer. So I thought I’d create my own test project with staccato notes following on from a hairpin to p. That one works OK! It’s clearly something specific a) to NPPE and b) to your project example. It’s possible that Arne Wallander could shed some light on it but you said initially the dynamics are not being played as written which suggests there are further issues elsewhere in the project. If you could give further examples, it might help but before that, I strongly advise resetting the NP PB configuration to default (i.e reapply the PB configuration) so we don’t confuse possible bugs which things you may have caused by experimenting with your own settings.

1 Like

Thanks for the effort @dko22 I really appreciate it. I’ll try your suggestion of resetting the NP PB config. however I don’t really know how it might have changed… I’m not one to really change stuff like that. Not intentionally anyway! So I’ll try to work on that part and see what happens.

Hoping Arne Wallander from NotePerformer might shed some light on that.

Thanks again @dko22

Edit: I see what you mean about the NP PB config. I set the default note timing to 105% which might extend the dynamic to the second note, but after changing it it stayed the same.


I think the problem is with the initial .xml file. as seen in the screenshot above. The CC data shows that its not really working with the indicated dynamics… That alone is concerning when relying on Dynamics to produce reasonably sounded mock-ups…

If one wants arne @Wallander to respond, it would probably help to tag him in your post (As I have just done).

I’ll be interested to see what he has to say.

1 Like

That was the intention, but couldn’t find the right tag. Thanks @Derrek

the main things I noticed about your playback settings – apart from what you said – were a much reduced curve power at only 1.5 instead of default 2.5 but on the other hand changing the max and min dynamic levels from 6 to 3. Pitch contour settings were also different. Of course it’s fine to experiment – I do so myself, but for troubleshooting purposes, I’m sure Wallander would expect his own default PB config settings. Incidentally, putting the non-legato default note length above 100% can cause other libraries to automatically assume you’re wanting legato or getting confused so it’s not something I’d particularly recommend in most cases unless you know the library well enough to be sure of what you’re doing. .

You’re 100% right I thought of that. I’ll set everything in the PB config. back to defaults as you suggested, I’m sure it will make a difference. Thanks again for looking deeply into the settings @dko22 , it gave me some perspective into settings I changed a long time ago. Even when it was in Dorico 4. I remember changing the settings of the pitch contour also that was introduced in Dorico 5. That might also add some complexity for NP… Dont know what @Wallander might add on this subject.

NotePerformer was aligned against Dorico’s default dymamics, so we advice against making any changes to the dynamic curve.

3 Likes

Thanks for the reply @Wallander

You suggest ALL settings in the playback options be changed to defaults? Also keeping the changes according to the suggested changes in the NP manual for Dorico?