Figured bass: Dorico insists on sharpened sixth despite 'follow input literally'

(Dorico I’d like to engrave a ‘6 over #’ figure. (There will be no discussion about it ;-).) This is what Shift-G, ‘6, #’ results in:


I tried many, many ways of inputting the figure: but each time I sharpen the third, the sixth also gets sharpened.

The Input Options are set to ‘Follow Input Literally’.

What should I do?

You also need to set the options to allow diminished intervals. Presumably, the interval between the sharpened third and the unsharpened 6th is a bit hairy.


The only way I can get the figure to behave the way you want it to (unless the key signature has at least three sharps) is to type the following: !6,s.

The chevrons around the n hide the natural sign. Oddly, when you re-open the figured bass popover for that figure you will see this: !6,#<3>, which is what should have happened when typing !6,s - but it doesn’t for some reason.

on reopening looks like this:

Thank you, @benwiggy ! This did the trick! ( It’s quite surprising that if the option ‘allow diminished intervals’ is not chosen, then ‘follow input literally’ does not follow input literally. Oh boy.)

@tbabcock123 , thank you very much for your response. I have to report that in my case, before I ‘allowed diminished intervals’, your proposal also sharpened the sixth!

1 Like

Hi Ben, I have the following settings for figured bass diminished intervals:

But which selection results in the desired figure of the OP. I’ve tried them all, and none of the options give the OP’s desired result.

@tbabcock123 , the following is doing the job in my case:

(I reach this point by invoking Ctrl-Shift-I)

Thanks! that was the preference I needed!

Those are Engraving Options (which thus specify how something appears), rather than Note Input Options (which controls how you enter it/how it’s interpreted).

The Engraving Options set the appearance of unmodified figures in diminished intervals. The Note Input Options is all about what you mean by what you write when there is a diminished.

1 Like

Oddly, when I typed the figure as shown in the top screenshot of my answer to you (! chevron then n then chevron then 6, s) the forum software removed the chevroned n!

You can use HTML code in your answers, so < and > can’t be used directly. :grin: