File name changed with computer change - how to get rid of error message

I just installed a new iMac computer, which is now running the Sonoma OS. The previous machine was 7 years old and could not be upgraded. Apparently in the file migration process the user name was changed from “rwt1” to “russ”.

Now I am getting an error message: “Error creating zip file: Users/rwt1/Library/Application Support/Steinberg/Dorico 5/AutoSave.” I can’t figure out how to tell Dorico the correct file location. In looking at the Library location, there is a folder with “russ” instead of “rwt1”. How can I get Dorico to point to the correct folder? I suppose I could just rename the new folder, but somehow that doesn’t seem like the right way to do it. The error message keeps popping up every few minutes and is getting to be annoying.

You should be able to do that in Preferences > General > Files > Saving Projects.

You can’t adjust the auto-save path in the Preferences dialog, I’m afraid. Russell, if you’re feeling brave, you can quit Dorico and edit the preferences.xml file in your text editor of choice (something like Visual Studio Code, Sublime Text, BBEdit, etc. but not Word or TextEdit!).

You’ll find the file in ~/Library/Application Support/Steinberg/Dorico 5 and it is, as I say, called preferences.xml. Look for the chunk that reads:

		<autoSavePath>
			<type>string</type>
			<value>Users/rwt1/Library/Application Support/Steinberg/Dorico 5/AutoSave</value>
		</autoSavePath>

and edit the <value> line to replace rwt1 with russ. Save and close the file. Now start Dorico up again, and auto-save should work as expected with no further complaints.

If you can’t handle this kind of hardcore text editing (and nobody will think any less of you if you decide it’s not for you), instead open the Preferences dialog and click the Reset to Factory button. You’ll need to spend a few minutes setting Dorico’s preferences back to your chosen defaults afterwards, but again, that pesky auto-save message will be a thing of the past.

1 Like

I wasn’t afraid to edit code. Used BBEdit and it worked just fine. Thanks! Better than redoing all my preferences. Great support!