File overwrite when using Export Batch Queues

Hi, when I manually export a mixdown and the target file already exists, Cubase will prompt me to ask whether I’d like the target file overwritten or not. I always want to, so I click yes, and that works.

When I set up and then execute several export jobs using the batch export/job queues functionality in the export dialog, it will not overwrite target files, but rather give them a new name (e.g. if a file called SONG.WAV already exists, Cubase will name the new file SONG-01.WAV when using the export queues).

Which means I either need to manually delete any target files that may already exist before executing the batch queue, or I need to manually rename all of the newly exported files after the export, which kind of defeats the idea of having fully automated export functionality.

Is there a way to tell Cubase to overwrite target files by default when using batch export?


In the Export Audio Mixdown window, you can find the File Location > Conflicts field. Set it to Always Overwrite, please.

1 Like

Ah, easy one, thank you so much @Martin.Jirsak ! No idea why I couldn’t figure this one out by myself…

One more thought on this: This setting will always overwrite files not just when doing a batch export (which is what I want!), but also when doing a manual (one-off) export. I’d love to have two separate settings for this: I want my export jobs to automatically overwrite (because correct file paths etc. have been locked in), but I’d like to still get the overwrite warning when I do manual exports - because I will do those while still sorting out file paths etc. and I don’t want to accidentally overwrite something. So, a #feature-request, and I tagged the post accordingly.