File won't save or print

UPDATE: Two users on the Dorico FB page copied and saved the project to a new file for me, but it gave me the same result. Dorico still freezes when I try to save those files, or copy and paste the material.

I’m at a loss. I’m going to move on in regards to this file, and simply re-enter it from scratch. But it is concerning to me, since I have no idea why this is happening.

The only reason why I’m taking so much time to post about this is that I want to help identify problems that may affect other users.

Have you done any edits to the Dorico “default” .xml or .json files? Just a wild guess.

I can’t imagine why user-defined preferences would stop a file saving, but it might be worth looking at the paths in there to see if anything doesn’t match your current file system. For example it’s trying to delete an autosaved copy of the project but it can’t access your autosave directory - just another guess but that’s the sort of thing I’m wondering about.

Can you export it as MIDI or MusicXML? That might give a clue if it really is corrupt.

Then again, it would be very weird if Daniel and the rest of the developers DIDN’T have an app to check the integrity of .dorico files anyway, for their own debugging use…

Dan - one thing to try is to clear the Dorico cache directory. If you open an explorer window and type %temp% then it should open a directory that’ll be something like c:\users<name>\AppData\Local\Temp. In there there’s a Dorico 2 directory. Ensure that Dorico isn’t running then delete the directory and start it again.

Thanks Paul. Daniel suggested that in an earlier comment, which I did. Unless that’s a different folder?

Update: A user shared a rough copy-paste file that I AM able to open and close successfully. But when I open it up, Dorico tried to give me a “tour” in each mode. What…? It’s like Dorico started over, thinking I’m a new user. And all my default settings are reset, apparently because I deleted the %appdata% folder. :frowning:

Did you empty your Recycle Bin? If not, you can always try moving your appdata folder back, a file at a time…

Brilliant. Any reason why it needs to be one file at a time? Can’t I just grab them all, and let Windows overwrite them?

Well you could do that too, I guess.

Alternatively, bear in mind that each project stores its own Engraving/Layout/Notation Options (and a few others). If it’s something in your appdata folder that’s causing the problem, why not open a file you were working on last week that uses your “defaults”, go through each of those dialogs and hit “Save as Default”?

This relates to the question on horizontal beams currently: does “Reset” affect only that page/menu (Beams or Chord Symbols, etc), or all Engraving Options at once?

I’m pretty sure it does the lot in one fell swoop.

It is a different folder. Sounds like you’ve deleted the one in %appdata%\Steinberg\Dorico 2, rather than the one in %TEMP%\Dorico 2. The one you deleted has your preferences, ‘save as default’ options and the file that records which pages you’ve already seen the Quick Tour for, which is why you’re seeing it again.

AGGHHH!!! It’s doing it again today. I deleted the %temp% folder, to no avail. All Dorico files open fine, except for this new problem file (different one than previously). Same behavior: if I try to save, or copy, Dorico hangs.

Thankfully I can edit and export as PDF, so I can distribute to orchestra tonight. I just can’t play, copy, or save, so all my changes are lost.

I don’t know if it’s pertinent, but in the case of this file, as well as the one before that was giving me problems, they were done by someone else and sent to me (a different person each time, though).

Also, when I set the Playback template to NotePerformer, it doesn’t actually load NP. At least, I’m not getting the spash screen for NP.

Any thoughts? Thanks team!
Before the Throne of God Above - Brass only - Eb.zip (877 KB)

Sorry to hear you’re having problems, Dan. I’ve tried opening that file in a Dorico debug build and it opens fine for me with no warnings. I can print to pdf (haven’t tried to a printer) and I can save it. If I switch to NotePerformer then it plays back quite happily with it. So I’m assuming there’s either some other problem on your system, or something specific in this file that’s conflicting with something unique to your machine.

If you’re getting a hang, rather than a crash, then it would be helpful to see a minidump. You can create one quite easily if you install MS Process Explorer (see Ulf’s steps here: https://www.steinberg.net/forums/viewtopic.php?f=246&t=141794&p=789978&hilit=process+explorer#p789938 ). Note that you need to create a minidump rather than a full dump (otherwise it creates massive files), and you can post to me p dot walmsley (a) steinberg dot de

When I opened it, the playback configuration seemed to be completely screwed. I got TWO copies of the Halion Symphonic Orchestra player, nether with any instruments loaded.

Loading the Halion SSE template, and NotePerformer, both worked.

Since it seemed to be trying to use Halion Symphonic Orchestra, I wonder whether your other user has Dorico Elements. That shouldn’t matter, but there is obviously something going wrong…

Thanks Paul, I will be sure to replicate that tonight and send it to you.

@Rob, I noted that as well. But he is using Pro and NP.

Curiously, I asked my collaborator to save the file as both a Silence version and a NP version. He emailed me those files, and both work just fine. The original offending file continues to make Dorico hang.

Still pursuing this since something is amiss, but at least this particular file is fixed for me.

Paul, I emailed you the minidump files. Thanks.

Thanks for sending those Dan. I can see that Dorico is hanging as it’s waiting for the audio engine to save its data to file, which in turn is waiting for HALion Sonic SE to finish writing its data. For some reason, the call into the OS is hanging when it’s trying to either create or access a file, though I can’t see which file. I think there are two likely possible causes.

One is that the file can’t be opened because it’s locked by something else (eg virus checkers).

The other strange thing is that this project uses the HSO plugin directly, rather than using the HSO samples in Halion Sonic SE. I would suggest resetting the playback template to HSSE Pro and save again, to see if that fixes it. The HSO plugin itself is ages old, but really it’s just a reskinned version of HSSE. It could be that there’s a HSO/HSSE conflict that’s arisen.

In my mind all this points to the fact that the collaborator has somehow got an outdated version of HSO that works for him/her, but isn’t compatible with the current version of Halion that works with Dorico.

That seems like a general (and in the general case insoluble) issue with transferring a VST playback configuration from one machine to another. If the configuration says “this uses the VST component XYZ.dll” and the recipient’s version of XYZ.dll is a completely different VST, all bets are off as to what happens after that.

Maybe the collaborator’s version of HSO originally came from a different Steinberg product?

Yes, that sounds very plausible. I don’t think that there are any reasons for needing to use HSO directly in Dorico - it’s far better to use the sounds in HSSE. I would encourage your colleague to reset to the default HSSE playback template to reduce the potential for future problems.

Thanks Paul and Rob, I will try that with him. Still strange that, with this file and the previous one, my machine was the only one that had problems with the file.

As a perhaps related question, any idea how I can completely remove Iconica from my machine? I got the trial a couple months ago, and every once in a while, I get a popup message saying “We can’t find Iconica and we are most seriously displeased.” Or something like that.

I’m not sure. Try running the HALion Library Manager and remove it from there. I don’t know whether that will actually just unregister the library in HALion or remove it totally though.