Filling frame with blank staves

I am trying this way of making MS paper, by using the fill frame with blank staves function. I am using a sketch staff. I follow the instructions in the manual. but I get a completely black screen, not a blank white sheet or a page with staves, and the setting for number of blank staves in the page layout is always 5 and greyed out, and I cannot change it.


Missing something fundamental in my understanding.

Can you share your project?

Was just about to! Dorico very latest version, Windows 11 Insider Preview line, up to date.

Blank staffs blank.dorico (481.0 KB)

I followed the manual precisely in detail, or so I believe.

There are no pages and the music area is black because the default page template frame chain is set to show blank staves, rather than flows.

The note in step 1 of the task for showing blank staves in frames says:

We do not recommend showing blank staves in the default page template frame chain, which is usually “MA”.

Your project:

The simplest way to get a specified number of pages of blank staves, is to add blank pages and manually draw in music frames, and set those layout music frames to show blank staves.

blank_staves_LH.dorico (387.1 KB)

(Playback template in the above example project is set to “Silence” to make the file size smaller)

Oh yes and the Layout Option for staff lines – I think that’s related to showing blank staves to fill the rest of a partially-filled final page, rather than blank staves shown in specific music frames.

Thanks. I’ll try.
But as to the line ‘we don’t recommend showing blank staves in the default page template frame’ I confess I do not understand why. I don’t think that is explained. So, why not? What does it do, or not do? I will say that the description of Layout Option for staff lines is highly subject to misunderstanding. I read that as setting how many staves per page. No wonder I am confused.

Why do you have to add blank pages? What do I then do with the first pages? This seems strange.

“Why not” – as you discovered, you don’t end up with useable results (a black music area). When the manual offers recommendations, they’re generally useful pieces of advice that are worth following; a comprehensive explanation of the details would often be superfluous or simply too complicated to be worth including, given that it’s something you’re better off not doing in the first place.

You have to add blank pages because the blank staves aren’t going to come from the automatically-generated pages, which use the Default/First page templates and the MA frame chain.

You could, of course, create another page template with another music frame chain, not MA, and set that to show blank staves and apply this custom page template to the pages on which you want to show blank staves – but unless you want to show blank staves on lots of pages in between other music (like on pages 2, 4, 6, and 8 in a 9-page exercise booklet with lots of short flows for other musical excerpts on the odd-numbered pages) I suspect that’s more effort than it’s worth.

Nothing: ignore them, don’t use them. Done. (Edit: if you look at the project I attached in my previous reply, you’ll see I removed the single flow in the project from the full score layout, meaning there were no other pages in the layout.)

Hmm. This is too hard for me.

I still say it would be better if we were told why not, because I still don’t understand the problem the manual is wanting to avoid. I am not criticizing you @Lillie_Harris , I just don’t follow the rationale or the practice of doing this. I think the Layout Option is outright wrong.

Ignore the first pages? Then how do you stop them printing? There’s something very clunky about this procedure.

Try opening the project I attached and taking a look at how I set that up.

Missed that.

But now, if I add blank pages and add music frames I see how to do that. But then I can go back and so the same on the first page. Why does that now become possible, with the MA frame chain?

Probably because the pages are locked into place by the existence of subsequent page overrides. I can’t remember exactly, but I suspect the reason it doesn’t work initially is because Dorico uses the amount of music in the flows in the MA frame chain to work out how many pages to create, dynamically; when it’s not got any concrete flows to show, it has no way of knowing how many pages to create.

I’ve made a note to double-check exactly why we added the recommendation about not setting the MA frame chain to show blank staves, but I make no promises about changing the documentation as a result.

1 Like

Hey thanks! Great! I do appreciate your help. I think I missed the Dorico Dolt of the Year Award last Year (not awarded!), but I am going for it this year.

1 Like