Filling gaps between events WITHOUT time warp?

Is it possible to fill in those microscopic gaps (seen only when zooming far in) between events globally without utilizing time warp? I simply want events to drag so to be larger (or smaller) in order to run precisely against one another (preferably exactly on the beat).

Essentially I’m looking for an automated way of dragging events precisely together without processing the wave forms.

You could use a very short crossfade.

Highlight all events, hit x and then open fade editor and reduce the length to 0.0.0.6…obviously you can change this length but this seems to work for me in most instances and is imperceptible.

You can also mark all events and use the “close gap (crossfades)” function in the audio menu.

thanks for the replies, best solution for what I’m trying to do so far seems to be the 0.6 crossfade since I don’t want to process the wave forms (creates some funky artifacts and limits future editing outside of event cutoffs). If there is no way to make sure every event starts and ends exactly on the same beat without any dead space I guess I’m stuck w/ that, or then zooming in to a microscopic level and dragging each event over individually…

I uploaded a screen of the event gap in case anyone else wants to take a stab at this problem.
cubase-eventgap.jpg

If there is no way to make sure every event starts and ends exactly on the same beat without any dead space

Well of course there are ways to make events start/end exactly on a beat, but whether you can make your events do it depends on what the events are I guess …maybe you should explain in more detail what you are trying to achieve. Are you editing takes, cutting and pasting an arrangement from samples, is your audio played to a fixed tempo…to the DAW tempo or more free time??

How about just gluing the events together then cutting again if needed?

How about just gluing the events together then cutting again if needed?

This creates a part rather than a longer event and also leaves any gaps intact.

I was thinking that an “event” and “part” are pretty much the same and thought that was exactly what the OP wanted to do… be able to drag events together without processing the waveforms. Maybe I’m missing what the difference is between “event” and “part”?

Thanks for the replies so far. Tempo is fixed without any changes. I’m not concerned about matching wave forms at zero, as much as there being the miniscule silence gaps between events. I can deal with overt clipping issues if they occur. Bouncing everything and chopping does not fix the issue as those gaps translate to silence and thus the bounced waveform includes that silence in it.

As of right now when zoomed out everything looks like it lines up, but when zoomed in like that things are uneven and there are gaps between events. My suspicion is this is actually what occurs for most of you, you just haven’t inspected your own materials as closely (at max zoom on every 2 event boundaries). Maybe this is some automated way Cubase does things to make material chopped up in precise bars not sound so robotic? I don’t know…

I’m just trying to get everything to line up perfectly, cross fading introduces some anomalies in that it exaggerates natural pauses, time warp processes the sound so I can no longer stretch the events past their pre-warp boundary (I lose that information outside the boundary as time warping effectively chops it off).

So far the best solution seems to be the 0.6 crossfade on every junction (as it forces boundaries to overlap slightly) but this is not as ideal due to my previously stated concerns with cross-fading.

My suspicion is this is actually what occurs for most of you, you just haven’t inspected your own materials as closely (at max zoom on every 2 event boundaries). Maybe this is some automated way Cubase does things to make material chopped up in precise bars not sound so robotic? I don’t know.

The only thing you said there that makes any sense at all is “I dont know”. :wink: I promise you that my bars start and end exactly where I intend them too.

Check these things:
Snap value set to Bar
Snap type set to Grid
Snap to zero crossing switched off
In transport bar where it says TEMPO it says FIXED

Now with scissor tool cut a bar of audio in the middle of an event and highlight it…in the info line it tells you start and end points and length which should read 1.0.0.0. Assuming that is correct drag that bar anywhere you like and drop…check in the info line the start and end point is x.x.x.0 (i.e ends with a zero)…or you can zoom in as you have been and see if it lines up to 0.

You missed the point entirely. I can zoom in and stretch every event to exactly where I want and it will only take me 48 hours to complete a song…

I was looking for a way to automatically adjust ALL event durations so they start and stop exactly on each others boundaries. This is something I had assumed the program would do anyway, which it clearly did not, since I am having this problem, congratulations if you don’t.

You missed the point entirely. I can zoom in and stretch every event to exactly where I want and it will only take me 48 hours to complete a song…

I gave you the best simple fix for the project you already made this way in my very first post so please don’t tell me I’m missing the point :unamused:
my last post is about trying to get you to see how you could be working to avoid the problem in the first place.
This is not a Cubase problem, it is a problem YOU are creating. That’s why you don’t see anyone else complaining about it.

Anyhow thanks for your sarcastic congratulations…I’ll leave you to your 48 hours of gap closing. Have fun.

Do not cast your pearls before swine.

In the SE you need to set the sample start point. Then it will snap properly.

Either that or you are fighting a zero crossing option.