Firewire problems Cubase and RME

RME UFX and Windows 10 64bit and Firewire booting problem:

My UFX (recently sent in for repair since it “died” just within the 24 months warranty) always worked fine with windows 7 64bit and Cubase, also when i upgraded from within Windows 7 to 10. Of course using the Legacy 1394 driver with Windows 7. PCIe VIA 1394 compliant Firewire card. I especially bought the UFX for Firewire, as don’t like USB, to many issues especially with dongles, external drives and also experienced dropouts with a Yamaha 01v96i digital USB mixing board connected.

However i finally decided to do a fresh install of Windows 10 64bit. Half of the times booting my PC the UFX is not recognized by the card. Drives me crazy. It’s with both the “standard” 1394 compliant drivers AND also the Legacy version i just specially installed. WHAT CAN BE THE PROBLEM? Only a reboot of the PC fixes it mostly. ASUS x99 USB 3.1 mainboard, latest BIOS, USB and chipset drivers installed.

PS connected via USB, and a USB 3.0 port to boot. it works flawlessly … thanks, F

A few thoughts…

Make sure all of the mobo drivers are the latest versions. I suppose you would go to the Asus site for those.

Check with RME to see if there is a new driver specifically for your RME audio interface available.

Reseat the firewire card to ensure no loose connection.

Check Win 10 power settings section for what is set for the firewire card.

Regards. :sunglasses:

I did all that except for the one above - have to look into that ! Thanks, F

You could try a different PCIe slot, that will change the IRQ in case it is shared with some other hardware.
You can sort the list in Windows device manager by IRQ, that makes it easy to see if it is shared by another device.

Firmware in the UFX?

As you know the Firewire, and USB firmware are different updates, but are both updated at the same time using the USB firmware updater!


I ran the UFX’ USB-Firmware installer, 1.63 seems the latest, refreshed it, and the problem still exists … I seriously think it’s windows 10 related … booted into my old windows 7 and all is well, as it has been in the past. Just dumped and reinstalled the legacy 1394 driver, and with out a reboot it’s working now. Device manager shows only one IRQ (26) related to the PCI bus and the legacy 1394 driver … F

The traditional answer to all Firewire problems was always ‘Make sure your Firewire card uses the Texas Instruments chipset’.

Be sure that firewire is recognized in windows check “device manager” if all is good
Check if RME is in PC mode by clicking twice rotary encoder button while it is only on power supply (not connected on computer) You will see on unit display PC=PC mode or
AP=Mac mode

Also check if it works on usb. There is a chance that you have problem with your FW on your computer or maybe FW controller is dead on the unit itself (its weak point on most FW audio cards)

FWIW, I found the UFX better over USB than FW on Windows (7). Only found out when the FW chip blew in the UFX and was forced to use USB in the middle of a session! As long as it has its own dedicated bus, USB has been rock solid. USB was certainly more reliable when using Pro Tools than FW (but that’s another story - and why I’m now on Cubase!).

Thanks all, i will maybe switch to USB then, if i can’t find the solution … a pro theater equipment friend & dealer suggested the MAHDI system as being far better, but for the price LoL … F


which motherboard chipset do you have?

FW 400 cards won’t sync properly on chipset like the X99, H97/99, Z170, etc., so if using a recent generation, you would need to get a IEEE1394b/FW800 card (ideally, one that also have a FW400 connection). Some users had some success using the Legacy driver on Win 10 (installed using the signed MS installer for Win 8), but far from perfectly reliable.

Hello Fabio, ASUS USB 3.1, x99, but as stated it worked with windows 7 64bit for about a year flawlessly with the same (non FW800) VIA OHCI card (TI chip i think). Have the latest ASUS chipset drivers (from intel?) installed. Since i have Win 10 running the caboose the firewire-RME stuff has problems. I’ve been looking at another FW card with 1394a/ and - b, but buying yet another FW card at around 40 euro’s is a bit much for a “maybe” solution. I’ll check your tip with RME first. Alas i’ll be out for about a week, but i will post eventual findings here … thanks F

Hello Grada. Found this in the CC manual :

Activation of the Class Compliant mode: Remove USB and FireWire cable from the UFX. Press SETUP/REV. Turn encoder 1 until Options appears in the display. Turn encoder 2 until Hardware/Diagnosis appears. Push encoder 2 several times to select the entry CC Mode. Turn encoder 2 to switch CC mode on (or off). The UFX reboots, all LEDs light up, after which it will be in Class Compliant mode.

I think CC mode has to do with USB and Ipad only? - Found CC mode was off, turned it on, but i did not see a PC or AP mode option. Still the FW connection has the same issues. Thanks, F

Ok that PC and AP modes are for uc units. Than revert back to normal mode. Check if its unit functional on USB if its yes than FW is your problem on PC or on fireface. The first can easily be solved by checking device manager if you see FW is recognized than you have to look on RME, its drivers and windows. You will clear any doubts by hooking some other FW audio interface and if it works than probably you have problem with Fireface. FW controller is the weakest point on those units. You can contact RME support or post question on their forum they are nice and I am sure you will solve the isaue.

The way this issue pops up is pretty system specific and also depends on the OS, particularly due to the Legacy driver on Win 7 (which you need to install separately on Win 10, I would not exclude that it gets dropped after an update), so that does not surprise me.
I had the same issue on my H97 chipset and Win 8.1 (Win 7 was better on that PC, but still not 100% usable for me).

Do check with RME first, but the issue described was discussed with a couple pro DAW builders, who confirmed they only use XIO2213B to avoid FW clock issues as of the Broadwell chipsets (X2200A actually went end of life 7 years ago).

Good luck!

Your card uses a via chipset (obviously) but that is fine. Half of the time these are firewire cable problems so do check that out. Also in device manager you have lots of options for the firewire driver for this card especially with the legacy installed too. Via 1394, OHCI 1394 and legacy version(s). Do try them all. You can see them all when you choose update driver, manual and choose yourself (or something like that).

I have a firewire device (Tascam FW1804) that only works 100% if I turn it on after windows boots. Luckily turning off and the on also helps if I have it on when booting.