First tryout with Cubasis and interapp audio

I’m trying out Cubasis for the first time and haven’t had a great time so far. I was initially excited about being to work with all my soft synths on the iPad, but vey little seems to be working for me. Either I’m doing something wrong or my expectations are too high for IAA

My soft synths are Animoog, Nave, Addictive Pro and a few drum machines, DrumJam etc.

Animoog fails to launch. I get an IAA error
Nave launches, but i get no sounds from the synth. Ive tried the Cubasis keyboard and the Nave one too.

Is this a typical experience?

Hi Tonty,

Thanks for your message.

Cubasis fully supports Audio Unit, Inter-App Audio and Audiobus 3.

While these 3rd party formats are fantastic to add external instruments and/or effects plug-in apps, they come with limitations, which we’ve listed in these forum articles:

Limitations of Audio Unit extensions
Limitations of Audio Unit automation
Limitations of Inter-App Audio
Limitations of Audiobus 3

In regards to IAA and AU, please note that the Audio Unit format can be seen as Apple’s successor of Inter-App Audio.

Best wishes,

Hi Tonty,

Please note that I gave Nave and Animoog a short check.
Both apps load and work fine with Cubasis.

These are the steps:

  • Lauch Cubasis and create a MIDI track
  • Please tap the small piano icon in the track
  • Please open the “Inter-App” folder and choose your desired instrument (e.g. Animoog or Waldorf:Nave)

No further steps should be required and both instruments should play and sound fine.

Nevertheless you might run into loading issues from time to time, which are common for the IAP format all DAW apps (and are untreated to Cubasis).
Here, reloading Cubasis and the project should help.

Hope that helps!

Best wishes,

Hi from Tokyo

I’m getting started with Cubasis and iPad Pro.

Issue: I can record/play/hear Cubasis instruments but cannot hear inter apps such as iProphet or Nanologue. The MIDI data is showing up on the track, but no sound.

At the same time, the internal Cubasis instruments record and playback with no problems.

Kind thanks to point out something obvious I am somehow missing.

All best.

Hi TokyoH,

Thank you for your message.

Here are the example steps to connect Cubasis to Nanologue:

  • Create a MIDI track
  • Tap the piano icon in the track (which will open the instrument rack)
  • Tap the “INSTRUMENTS” button in the instrument rack
  • Tap “Inter-App” in the left column and choose “Nanologue” from the list

If you do not hear back anything from an instrument assigned via IAA which has worked before, this can be caused by a disconnect of the app (related to Apple).In this case please close Cubasis and the IAA instrument app and load it again.

Inter-App Audio comes with some limitations which we’ve tried to sum up in our Limitations of Inter-App Audio article.

In addition, please note that Apple has introduced Audio Unit some time ago which can be seen as the successor of IAA (which is no longer supported by Apple, and will be discontinued sometime in the future).

Hope that helps!

Best wishes,