Fix a lyric spacing error

I’ve been using the trial version of Dorico for a couple weeks now and this is the first lyric spacing problem I’ve encountered. See attachment. I’m hoping there is an easy fix for this. I’ve already tried deleting and re-entering the lyrics here, but I keep getting the same compressed result. I have a couple other instances of the same type of issue in this piece which was imported into Dorico as a midi file. Otherwise, lyric entry has been a flawless process.

In Sibelius, whenever I’ve encountered compressed spacing like this, I could select the bar and re-apply ‘note spacing’ to correct the issue. How do I address this in Dorico? Re-entering these lyrics one word at a time and advancing with the space bar does not correct the problem here. I’ve applied no special note spacing to this file. Is there a logical cause for this kind of behavior? What is the preferred way to correct this kind of behavior in Dorico?

Thanks in advance.

There doesn’t seem to be an attachment. Make sure you zip it first.

Sorry. My attachment was rejected – zipped or otherwise. I just tried again but I got the the same warning message: “Sorry, the board attachment quota has been reached.” It’s only 11kb. I’ve posted only one other image to this forum, so I don’t understand the restriction.

I’ll describe the image: I’ve entered a span of lyrics into Dorico that are overlapping each other.“There’s only one thing to do” is the lyric.The words “one”, thing" and “to” are overlapping each other. i.e. Dorico has not auto-adjusted the note spacing to accommodate these words upon entry, as it normally does. The rhythm of the bar is simple, even eighth notes, in 4/4 time. It’s a single voice, and the vocal line is the only music in the flow at this point so I can’t determine a reason for the spacing error. The flow is part of large multi-flow, multi-instrumental musical work. I’m posting here for three reasons 1.) I’d like to know how I can fix this. 2.) Perhaps there is someone who can provide an explanation (aside from a possible bug) of why Dorico might do this given the parameters of my situation? 3.) As this type of error has happened twice in the same piece, I’d like to know of an easy solution to address the problem if it comes up again.

Thanks.

I think it’s a problem with the forum, not with your file. Others are getting the same message.

Hey Steinberg, your new notation program is so popular you’re gonna need to give its forum more bandwidth… :wink: [[Oh, and while we’re making Christmas lists, can we PLEASE just post images to the forum and have them appear without needing to paste the link?? Thanks…]]

billscores, are you possibly viewing it in Galley View? What happens when you view it in Page View?

It’s not your attachment quota that’s the problem - a forum admin needs to raise the cap on the whole forum’s attachment quota.
Without seeing the file (or at least a screenshot) I’m struggling to help you. Bear in mind that you can always host files elsewhere (Dropbox?) or screenshots elsewhere (e.g. imgur).

I just checked Galley view and the overlap exists there too. The overlap is in the part and the score/ and both page and galley views. I just tried to post an image again, but no luck, same attachment quota error. Perhaps the webmaster at Steinberg is taking some time off for the holidays.

What happens if you select the second lyric and flick the alignment switch in the bottom right corner of the properties panel? Sometimes works for me in these situations…

Okay. I posted a couple images to a custom page on my website. You can view the page here.

https://billwandel.com/?page_id=2424

I see the screenshot, but that’s not enough info to diagnose the problem. What is the note spacing fill percentage of the affected systems? Switch on Note Spacing and check the percentage on the right side. Are there signposts anywhere? Are the notes and lyrics all in the same voice? Without looking at the file, I’m just guessing.

Actually, looking at that, I’d definitely want to see the file. None of the lyrics look even remotely like Dorico default behaviour.

Bill, maybe you could trim down the file to remove bits you didn’t want public, and post it to that page on your site?

Thanks for the replies. I tried flicking the alignment switch of a selected problematic word, but it doesn’t fix it. As for “fill percentage” of affective systems, I’m not seeing a readout for this on the right (I don’t really know where to look) when I switch to Engrave mode and click the note spacing button. But I haven’t touched or moved any note spacing handles, or tinkered in Engrave mode at all yet if that’s what you’re asking. And yes, all the notes are in the same voice. I just tried deleting the lyric and re-entering. Same result. I wish I post a screen capture of that process, because that really says what I’m dealing with. Space bar advances to the next note, but no auto spacing is applied for the word “thing” so it gets squashed. As I said, lyric entry in Dorico has worked flawlessly for days, except for these two particular instances in this piece.

I recorded my screen to better illustrate the problem I’m having. You can view the video here.

https://www.youtube.com/watch?v=xiFGMokv8Cw&feature=youtu.be

I did some experimentation. So if I copy or move this improperly spaced music up or down a staff, the problem remains. If I copy and paste it elsewhere in the score, the spacing problem instantly corrects itself. However, if I then copy the corrected music and try to re-paste it in its origin location the spacing problem instantly returns. It’s bizarre. It’s as if there is a hidden, fixed note spacing encoded into this particular bar.

Please delete bars 1-100 and 115-end and upload the file somewhere where we can access it. It’s quite likely to be a 2 minute job, but only if we can actually play with the file.

Okay so I exported the flow and trimmed it down. You can download the file from my website as before. Here’s the link again. You’ll see the download link at the bottom of the page. Thanks.

https://billwandel.com/?page_id=2424

Copy bar 77 to bar 78, delete bar 77 and add it again. Copy from 78 to 77. Does that work for you? On my system that solves it.
I have no idea what causes this, but maybe it has to do with the MIDI import.

Thank you LAE. Yes this corrects the problem on my end. It’s an easy fix – your experiment helps to explain what might be happening here. The MIDI file I imported into Dorico has fairly aggressive tempo changes encoded throughout – particularly in these bars. (Take a look at the hidden signposts.) Unfortunately, deleting the bars in question also deletes the tempo information. It solves the issue, but deleting encoded tempo information won’t always be an option for me. It now seems clear to me that the tempo information in the file is causing this spacing anomaly. Probably something the Dorico programming team should take a look into.

CONFIRMED - selecting and deleting all the tempo information in the flow fixes all the lyric spacing errors. These particular tempo changes were imported into Dorico as part of a standard MIDI file. Curiously, although these tempo changes appear as ‘tempo signposts’, the same changes are not reflected in the PLAY view tempo timeline of the flow. Shouldn’t imported tempo information be visible in the PLAY view timeline as well as ‘sign posts’ in write mode? Perhaps this is an issue with MIDI import regarding the proper extraction of interpretation of tempo information? Just a thought.

They are visible for me. You have to scroll the Play mode display and/or zoom out to find them.

In this particular score you could probably replace them with rit and accel lines in Dorico - they don’t look like they have any “humanized” tempo variations.

It isn’t anything to do with MIDI import. I deleted all the original tempo marks and created some more within Dorico. As soon as you create a hidden mark “in between” two notes, the spacing goes wrong for the adjacent notes.

Maybe you can reduce the “quantization” of the tempo changes in whatever software created it, to match the note durations?