Fix the workspace and performance issues

So as the title suggests I’m quite fed up with Steinberg never fixing stuff. I’m on Mac and I know there’s a workaround by using whatever it’s called. Separate spaces or the opposite. Anyways, that affects how the whole system handles the displays and … that’s not how I work with my computer so it’s a no go. I’m using a M1 Max and I use 3 displays. Problem one is …well, I have to recall a workspace multiple times before ALL windows and plugins get to the right position and worse than that, the arrange window has to be on the screen where it’s supposed to be in the workspace for the arrange window to place itself correctly on that screen.

Workspaces are broken and when looking through this forum it feels like it has been for 7 years. (Switched to Mac recently, didn’t have this problem on PC and 2 screens).

The second weird problem that seriously needs to be fixed is the performance. I’ve looked around and I’m not alone in having performance spikes and the Asio Guard going crazy. I can have a project that I can’t play back, as my computer seems to be on it’s knees with mostly audio and live recordings but just selecting an instrument track makes Cubase play back the song with no effort at all. CLEARLY something is quite wrong. And the frustrating part is seeing how old all similar posts are on the topic. They’re not properly adressed, explained or …fixed. (I’d prefer the them being fixed)

And lastly, I just came across a feature that is CLEARLY missing from a PRO Daw. I think people usually refer to it as “multing”, something I’ve never had any need to do but just assumed I could somehow. Well, now I just got the Sound City plugin from UAD and thought I’d set up a virtual/fake room channel for my live drums… But how do I do that in Cubase? There’s no way to double the Drum Bus or send the same signal to two Busses/Groups in a simple way. Sure I can use pre fader sends and create a separate group but …then soloing the “room mic” becomes a problem. I can go to the settings and switch so that mutes don’t affect the pre fader send but then when I solo the “room” i need to …mute the channels manually anyways or they behave differently depending on if it’s a group track I’m sending from or not.

There’s simply no way to do it in the most basic way. Splitting the signal and sending it to two different Groups so it can be treated like a room mic when mixing.

I’ve been using Cubase for over 20 years, I work with music professionally and I truly feel every new version of Cubase is an improvement as far as tools and innovation goes. Vari Audio is amazing, the sampler track is the best new feature ever… But the never-resolving-issues that people have had for years and years needs to be fixed.

And the reason it needs to be fixed is because I do love working in Cubase.

1 Like

Direct Routing + Summing mode?

1 Like

Like Semarus wrote - Direct Routing in “Summing Mode”.

1 Like

Thanks both of you! Strange how I’ve never seen anyone mention this in any thread I’ve seen on the topic. It kind of works, for what I’m currently doing it will do fine, but I’ve noticed some limitations when it comes to routing groups that are routed to groups, then I run into the same mute-problem I did using sends. But I’ll play around with it some more, only spent 5 min setting it up and maybe there’s something I’m missing.

Hi @evilace

And sorry to hear about your issues with Cubase.

I would like to focus on the workspace problem first.
Which version of Cubase are you using?
Would you be able to provide a deterministic and minimal way of reproducing these issues?
We would also welcome a video, can be a private YT link or a wetransfer / dropbox / drive link. Thank you very much.

Reminder: We expect constructive exchanges from both our staff and our users. Swear words or insults are not tolerated on our forum and would lead to actions from the moderation team.

Hi! And sorry about the “not swearing-kind-of-swearing”, going for comedic effect. Anyways, yeah it’s easy to reproduce.

So I’m on Cubase 13 Pro but the issue has been present since 12 (guessing earlier based on precious forum posts but I switched from PC to mac and my 3 monitor setup was only used with 12).

So there’s 2 problems but I’ll start with the big one.
The arrangement window is unable to travel across displays, or rather it’s unable to travel from my main display to one of the side ones - going from a side display to the center display is no problem.

Like I said, I have 3 displays, one 4k center and two 1080 to the left and right of the main monitor.

In general I have two main workspaces, one for producing/editing with the arrangement window on the center display and one for mixing/recording live drums and instruments with mixer and stuff on the center display and the arrangement window on the left monitor. Also there’s lots of scopes and plugins.

Now if I’m on my mixing workspace with the arrangement window to the left I can switch to the workspace that has the arrangement window on the center display. But if I switch back to mixing again the arrangement window ends up behind the mixer and the plugins on the center display. Everything else ends up on the righ display (kind of, see problem 2)

It doesn’t matter if my starting template has the arrangement window on the left display or if I open a project saved with the arrangement window on the left display, it always goes to the center display by default and I need to move it manually. When I change my workspace I also need to manually move it.

More detail. If the arrangement window is between the center and left display it doesn’t work. If the arrangement window is on the left display entierly it works. It doesn’t need to be correctly sized for it to snap into it’s correct position as long as it’s 100% on the left display. Again, switching to having it on the main display works no matter where the arrangement window is. It’s a one way problem.

Problem 2:
I have master bus plugins and scopes and a lot of stuff in my workspaces and they all resize and snap into place exactly right - but not immediately. When I activate the workspaces some plugins or windows can be off but activating the key command again once or twice and everything is perfect (except the arrangement window).

So strange stuff indeed.

Hi @evilace

Thank you for reporting this issue. I have informed the relevant team to have a look at it.

Cheers,
Armand

additional info, because I was setting up a new template.

this seems to affect the performance metering gadget and also some plugins but in weird ways. use both the Bus Compressor and Tape from Softube and if I have two different workspaces, one with Bus Compressor and Tape on the right screen and the other on the left, while switching the Bus Compressor behaves correctly (after activating the workspace like 2-3 times) but the Tape plugin does not. I can always get it to my right screen but when it’s supposed to go to the left one it ends up on the center screen.

also noticed that resized plugins are inconsistent. works with softube and the Vision metering plugin but not TDR and Izotope for example.