[Fixed] Bug: Cubase freezes if macro is run from remote controller

Simple macro freezes Cubase for good, the only way is to kill the Cubase.exe and restart.

Reproducible each time:

  1. Create Macro:

Transport - Stop
Transport - Locate Previous Event
Transport - Loop Selection

  1. Assign the Mackie F1 (or whatever you like) in Generic Remote as a trigger for this new Macro ( it can be triggered from any external midi controller (note on or CC))

  2. start the recording of any material audio or midi.

  3. Now trigger the macro with F1.

The Cubase would freeze for 6s. If one press the F1 twice it freezes Cubase for good.

Interesting if the same is triggered by PC keyboard (any key can be assigned to run the macro) or with mouse (edit->macros->name of macro) - all works fine. But I want to run macros from foot remote controller not from keyboard.

Tested on Cubase 8.5 /9.0.1 /9.0.10 - on Windows 10 Pro PC.

The same behaviour in 9.0.20 - Steinberg could you please correct it?

Still not corrected in 9.0.30 :frowning:

Consider sending a ticket about this.

I tried your repro sequence, and was able to reproduce the problem, just as you say.

Excellent report, by the way. I will get it added to the list.

Not corrected in 9.5.10 :frowning:

What a nice surprise! I did not found it in 9.5.20 Version History - but this seems to be solved now - intentionally or unintentionally!
Big thanks Steinberg! I’m now one step closer to leave Ableton that I’m using only for live looping (also with problems). If in next version you would introduce tap tempo from midi (like in Ableton) this would mean complete move to Cubase for me :slight_smile: