[FIXED by v9.5.40 update] Cubase corrupts .cpr files that reach 1.99GB by blowing them up to exactly 4,194,305 KB

Hi again!!

A problem that I had last fall has resurfaced.

I’m running Cubase Pro 9.5.10 on a Win10 Professional x64 machine, although the exact same thing was happening in Cubase Pro 8.5.

I’m trying to build a master project template (.cpr) file containing a track for each and every instrument.

On each track, the instrument is loaded and then ‘disabled’ to save resources and minimize file size. I’ve got a lot of instruments, so the file has been slowly growing for some time.

What I discovered last fall before sidelining the project, and I am rediscovering today, is that Cubase is corrupting the .cpr file each time it reaches 1.99GB in size.

This is particularly insidious, because Cubase doesn’t announce a problem with the file at the time of file corruption . . . it allows me to add additional instruments and incrementally save the project file every few minutes with sequential filenames.

Only later, after I’ve closed the .cpr file and then try to re-open it, do I get the following weird error message:

Project “filename.cpr” was created with Cubase 1.x. This program version cannot load it.

The Project was, of course, created in Cubase Pro v9.5.10, moments ago…

In each instance, the corrupted files are always the exact same size: 4,194,305 KB, which shows up as “4.00GB” in Windows Explorer.

Sometimes I’ll have to go back three or four iterations of the .cpr file before I’ll find one that will open. Looking in Windows Explorer, I’ll see that the last several iterations of the file are all exactly 4,194,305 KB, even though Cubase allowed me to add more instruments and re-save each sequential version. It’s not until I CLOSED THE FILE that Cubase rendered it un-reopenable.

The ‘last good version’ of the file always shows up in WIndows Explorer as 1.99GB, though the file size varies slightly (2,096,988 KB… 2,095,426 KB… etc.). It seems that the minute I try to add the instrument track that pushes the .cpr file size over 2GB, Cubase doubles the file size to 4.00GB, and otherwise renders the file corrupted and un-reopenable-once-closed (this is also true to .bak files)… all without ever letting me know that there’s a problem.

Why does Cubase choke each and every time that one of my .cpr files hit 1.99GB?

I couldn’t find any reference to a maximum .cpr file size. Is there one? Are there folks on this Forum working with larger .cpr files?

I’m running Win10 Professional x64, with 16GB of installed memory. Physical memory isn’t the issue — could it be a Windows virtual memory allocation issue?

Why does Cubase mysteriously double the newly-corrupted .cpr file size, always to exactly 4,194,305 KB and maintain that file size through subsequent iterations, even as it lets me add more material to the template?

On a related point, why does Cubase allow me to keep adding more material to the file after it had already doubled the size to 4GB, so that I don’t notice a problem until the end of the work session when I close the project . . . and then, some time later, try to re-open the .cpr file?

What in the world is going on here?!?!?

I don’t know about Cubase specifically but during saving files are sometimes much larger than their final size, thus possibly the 4Gb files. I assume this isn’t then being compounded by your drive formatting? You are using NTFS drives I assume and not FAT32?

Hi, planarchist.

That wouldn’t be the issue here.

The drives are all NTFS.

The .cpr file has grown, slowly, over a very long time. Each additional instrument track adds a few KB to the file size. Each subsequent iteration of the .cpr file is a few MB larger than the previous.

Everything proceeded as expected from when the .cpr was only a few KB in size until it approached 2GB.

You can see the last two day’s worth of work (out of several months) in this screenshot from Windows Explorer:

The .cpr file was at 1,756,464KB on Feb. 25, and grew by a few MB with each successive iteration.

The last ‘good’ (i.e., open-able) iteration of the .cpr file is 2,085,697KB (or, as Windows Explorer would display if it were highlighted, ‘1.99GB’).

As you can see, I continued adding more instrument tracks, and incrementally re-saved the .cpr file three more times in the same session (those are the three highlighted files at the bottom). Each time, Cubase let me ‘Save As’, and offered no hint that anything was wrong. Each time, the resulting filesize remained the same, even though I had added further instrument tracks.

Later, I tried opening the last version, and got the weird “Project “2018.02.27 - 10 - adding tracks.cpr” was created with Cubase 1.x. This program version cannot load it” message. Got the same error message on the previous two versions.

I’ve got 16GB of installed RAM, and I’m running on a 64-bit Win10 system.

This is definitely an issue with the way Cubase handles .cpr files as they pass 2GB in size.

See this: 4GB File Limit on Orchestral Templates???? - #18 by steve - Cubase - Steinberg Forums

Not exactly the same but has the corruption at 4gb.

…ah, yes, thought it sounded familiar…does sound like the same kind of problem.

Thank you -steve- for letting me know that at least it isn’t just me having this problem!!!

I’m surprised that @Martin.Jirsak was able to open a 4.29GB .cpr file, since I’ve never been able to get a .cpr file to cross the 2GB threshhold without running into that crazy “created with Cubase 1.x” error message.

Martin, please get in touch with me — I can provide the devs with TONS of pre- and post-corrupted .cpr files (and screenshots and possibly-related crash dump files), created in both Cubase Pro v8.5 and 9.5… I’ll do whatever I can to help Steinberg fix this problem!!!

If the devs thought that it would help, and if I knew that they’d actually review it, I’d open my largest ‘good’ file, and run procmon while adding enough instruments to push the .cpr file across the 2GB threshhold. Perhaps they could see what Cubase does at that point, when I re-save the file, when I close the file, and when I try to re-open the file.

Hi ArsPerspicuus,

Thank you very much. The projects would be highly appreciated! Could you put them to a Dropbox folder, and send me the link via Private Message, please?

Btw, I couldn’t open the 4.29GB .cpr file, as I wrote in the linked thread:

Last file size (when I > cannot > open it anymore) is 4.29GB


Obviously going over 2Gb you’re crossing a bit boundary (31 to 32) I’m sure this isn’t a co-incidence - sounds like a programming error ie a 32bit signed field overflowing (one bit used to mean negative or positive value) then moved to a 32bit field as binary 11111111111111111111111111111111 = 4Gb.

Thanks for posting the files…i have found the problem…will be fixed in a next update


Will it be a simple or difficult fix?

Any idea how soon the fix will be ready for public enjoyment? You see, I’ve got these two massive template files that really need to be combined in order for my fantasy future workflow to become reality, and . . . . . :slight_smile:

Hi folks.

I am having the same problem. Its really holding back my template development.

9.5 Pro on Windows 10 64bit

When will the fix be available, could we get a build to patch the problem please?

Many thanks


It should be fixed with the next update release.

Do you expect those 4gb cpr files to be in some way recoverable?

Do we have an ETA on the next update please? This issue is killing us here.


Could you try with Cubase 9.5.30, please? It should be fixed for a files in range 2 - 4 GB. Files bigger then 4 GB are not fixed, as far as I know.

I looked through the 9.5.30 release notes when it came out, and saw no mention of it in there.

Then I installed 9.5.30 and, unfortunately, the problem has not been fixed… at least for me.

Although I now get a different error message than I had previously gotten, I still have the problem every time I take an existing (and functional) 1.99GB file and add instrument tracks to it until it crosses the 2GB line . . . at which point it crashes or causes a ‘serious error’ in Cubase.

If a fix was actually rolled out, and if some folks can now build project files that are larger than 2GB, the immediate question becomes whether brand new project files can now go as high as 3.99GB, but pre-‘fix’ files have something ‘baked into’ their structure, so that they will always cause problems at the 2GB mark, even post-‘fix’, and will have to be re-built, from scratch…???

@Martin.Jirsak and @ygrabit, please check your Inboxes, there is a PM with some additional info and downloadable data waiting for you… :slight_smile:


PM replied.

Thanks. BUT I just had the problem here today, for the first time ever.
New 9,5 Pro with latest update 9.5.30.
Mac OS 10.9
What happened with the fix? What can I do?

the 9.5.40 or 9.5.41 should fix this kind of issue…

Thanks for delving in, and the feedback.
Not bad at all. Well done. :grin::+1: