[FIXED] Cubase jerky mouse movement and GUI flickering

After many advise within this forum and lots of trials I finally figured out how to fix jerky mouse movement and flickering while playback in Cubase.
Many people gave me the advise to install the studio drivers of Nvidia instead of the game drivers. Some people mentioned to turn off gaming mode in Windows. Others pointed out to enable Prefer maximum performance in the Power management mode of Ndidia control panel.
The results where not consistent and it was difficult to distinguish what is causing what.
Then I decided to go with the scientific method.
After I was able to get my system working (no jerky mouse movement and no flickering) I analyzed what my GPU is doing.
Remark: Cubase is using GPU for its GUI drawing.

Tools Used
I used TechPowerUp GPU-Z any looked at my GPU performance.

Steps
Then I started changing parameters:

  1. I installed an old studio driver (good)
  2. I installed latest studio driver (bad)
  3. I installed an old studio driver (good)
  4. I installed latest studio driver (bad)
  5. I changed the power setting (good)
  6. I installed latest game driver (bad)
  7. I changed the power setting (bad)
  8. I rebooted (good)

Observation
I used a complex song for playback with many midi notes and complex virtual vst plugins with which it was possible to reproduce the bad behavior easily.
I noticed that when the mouse movement was jerky and the GUI was flickering the GPU was actually running at a very low frequency: 420MHz


That is very low. The GPU reduce frequency because it felt bored. It is also only using 10 Watt

I noticed that when the when Cubase was feeling good, no jerky mouse movement and GUI flickering, the GPU was running at a much higher frequency: 1350MHz
That is almost 10 times faster. It is using 20 Watt in this mode.

Solution
The trick is actually only to enable Prefer maximum performance in the Power management mode of Ndidia control panel.

Sometime rebooting is needed. You can check usign GPU-Z.
If your GPU is running with a low frequency, then it is saving power because it believes that the system is not busy.

1 Like

Nice one. I will try some similar settings for the RX cards. It is horrible for me

How did you get on with testing this in an AMD (RXxxx GPU card) environment, Glenn?
I had a stable system until I installed Cubase 13, whereupon the GUI got slow and laggy, with a jerky Project Cursor. I tried to address the jerky Project Cursor issue by installing a new AMD RX580 graphics card (my previous one was essentially a legacy card).
Unfortunately, this appears to have made matters considerably worse - the Project Cursor is now near-stationary during playback and the controls become almost entirely unresponsive.
I was wondering whether you found any solutions or workarounds?

Cubase 13.0.30 is running just fine for me since 13.0.10 and that fix through the AMD Catalyst software

Thanks, Glenn … I must just be unlucky(?)!
To be honest, I’m somewhat pi$$€d off with Steinberg’s lack of responsiveness to my fault ticket, though.
They’re beginning to emulate Native Instruments’ insouciance in this respect.
Back to the drawing board…