FLAC output = Silence and other issues

So I loaded an album into 7.2.1, at 16/44.1
Added track markers.
Render output to FLAC, bypassing Master Section.
Result was silence.
Why?

Also I tried to render a set at 24/96 in FLAC, and the output was at 16/96 instead.
Why?
flac error.PNG

I can’t reproduce any of these.
In you picture, you render the “selection”, not the whole file… normal?
And what are the settings of the Audio File Format edit box?

Selection is exactly what I want - I am creating a single FLAC file for each track.
It has to be done this way as there are no FLAC players that can handle a long export with track markers (I asked about this one already).
Settings in box are 16-bits, 44.1kHz, Stereo, Level 8.

I forced the 16-bits even though it is a 16-bit file, as I have had problems with a 24/96 encode coming out as 16/96 when left as default “from stream” settings.
Same tracks rendered to WAV using everything EXACTLY the same - except for codec - works, but to FLAC gives me silence.

No problem to render a selection rather than a whole file.
Is it true digital silence you get?
Did you zoom in?
Did you decode the FLAC with WaveLab or another app?

Hi PG.

True digital silence was the result.
I tried several options, including playing the FLAC file after transfer to a mobile device, decoding in Adone Audition, Decoding in Cubase 6 & decoding in WaveLab. All gave me digital silence.

On further examination, I have discovered the cause of the problem.
If you pull the master section faders down (in my case to -50dB) - I did this because I did not want to blast the speakers - and then encode, even with “bypass master section” enabled the result is digital silence.
Screen grab of exact settings below…I am trying to find out what the point is where dropping master section faders causes this bug to trigger.
flac error 2.PNG
EDIT.

Bypass Master Section simply is not working. It is getting gradually lower with each reduction of level, and hits digital silence eventually. -10dB on faders gives me a file with massively reduced levels. -20dB makes it close to inaudible. -30 is as close to silence as it can be, lower than that gives totally dead levels.

“bypass master section” is only for playback, to play the rendered file without the Master Section. This is a new feature of WaveLab 7 as this option is per file (icon at the bottom right of the document).

Rendering without the Master Section would not make sense (that would be the same as using “Save as”).

That is seriously confusing then. Why is the option even there on the “render” dialogue?
Surely, if the “bypass master section” is non-functional in render, it should certainly not be present in the “render” dialogue as there is frankly no point in having it there. What is it for, if rendering with this bypassed gives a reduced output?
I think this option needs to be removed from the render dialogue.

If you read carefully you will see that it says “bypass master section on resulting audio file”.
I think this is quite clear. If this option is checked, then you get the same result as in WL6, where the resulting audio file was automatically bypassed.

but something isn’t right with Bypass… in the Render dialog, on OSX
I get the same results on/off if I select faders in Master Section
set to -10.2 dB and Render in place, shouldn’t Bypass mean
the complete Master Section or is it only for EFX !?

regards S-EH

S-EH is correct, it is the same on Windows: The complete master section bypass button (red button in the right bottom corner) bypasses the faders only for playback, not for rendering. This is unexpected to me. A bug?

Exactly!
I was hitting the bypass from within the render dialogue, not from the bypass button on the master section itself. Also, if I have “bypass master section” checked with the master section faders at 0dB I get a correct file.
It ONLY happens when bypass master section is checked, and the faders are down…
if I am truly bypassimng the master section, then silence should result every time.
But it doesn’t - try it. Render a file with Bypass master section checked in render dialogue with faders at 0dB.
Result = perfect.
Now try it with the faders down to -10dB
Result = attenuated file
By the time you get to -50 - it is silent - even with "bypass master section checked, which should not happen.
It’s broken

Sorry, but I see nothing broken. Everything works as expected and documented, see attachment.
2012-01-06_19-16-26.png
2012-01-06_19-15-14.png
2012-01-06_19-14-11.png

I do not see how it is possible for this to be as designed.
Sorry.
I expect “Bypass Master Section” as accessed from the “render” dialogue to do just that - bypass the master section, and not to take the faders into account.

The current wording is:
“Bypass Master Section on resulting Audio File”

If you have another wording that better describes this feature, you are welcome.
Maybe
“Bypass Master Section for playback of resulting Audio File” ?

How is this implemented? If the resulting file has a mark or flag placed in it which causes the Master Section to be bypassed when it is played back by WaveLab, then perhaps the wording should say exactly that:

“Mark resulting audio file to bypass Master Section on playback.”

Paul

We are not talking about the “bypass master section on resulting audio file”.
We are talking about the bypass button at the very right bottom (PG’s second attached picture with the 19-15-14 at the end). It is strange that this looks at the master fader settings only during playback but ignores them for rendering.
This is what S-EH and myself were talking about and I think Neil means this one, too.

OK, so the help text for that, which reads: “If this is deactivated, the Master Section is ignored during playback, freeing up resources. Rendering to file is still possible, however.” should have the last sentence modified to read: “… However, the Master Section will still be used when rendering to file.”

Paul

Nope.
I mean the one in the render dialogue, as I have said several times. Although your one is also very odd too.

@PG - that would be much, much better. (IE your last suggestion)
As it is currently wqritten, I expect the master section to be completely bypassed on tghe resulting Audio File, as it clearly says. Not to have attenuation applied according to the fader level.

Ah, I understand. Sorry for the confusion.

It is less the help text which is irritating but the function itself. If effects and master fader settings are ignored for rendering there is only little difference to the other bypass at the lower left corner of the master section (only the different treatment of master faders during playback).
What I find most irritating is that the symbol is the same as for the switching on/off of the single plugins, but the behaviour is different: Switching the plugins off also ignores them for rendering, the same symbol for the master section does not ignore anything during rendering.

My idea is to add an explicit option, inside the Render dialog, to optionally bypass the Master Section for the rendering.