{flat}: { doesn't work (Option + 8}

Hi,

I want to change the Trumpet to Trumpet B {flat} in “Layout”: curly brackets, the shortcuts Option + 8 and Option + 9 don’t work.

Best Regards
Hubert

macOS Catalina Version 10.15.6
German Keyboard, Dorico language: English
Dorico Pro3 Version 3.5.0.1020 (May 18 2020)
Dorico 3.5 AudioEngine Version 3.1.0.3

You need a @ between the curly brackets and the flat, e.g. “Trumpet in B{@flat@}”.

Sorry I mistyped, but the Key Commands Option + 8 and +9 for the bracket don’t work…
Under Key Commands Dorico says: Key sequence already assigned to: UI>

Workaround: I go to Layout or an Editor and copy the sequence {@flat@} to the clipboard and paste it.

But were can I find and delete the assigned Key Commands?

Isn’t it option shift 8 and 9?

Jesper

I believe the problem is that there are factory shortcuts to set focus to various panels that directly conflict with the German key combinations for brackets.
These are the relevant lines:

Hopefully someone from the development team will be able to provide you with best practice for how to remove these shortcuts - they’re not accessible from within Dorico’s Preferences, unfortunately.

In the meantime, do see if it makes a different using the right Opt key rather than the left Opt key, and failing that, try copying and pasting the brackets from somewhere else.

Ah, missed the German keyboard in the signature.

Jesper

Shift + 8 with German Keyboard: (
Shift + 9: )

To make my answer even more stupid, I’m using a Swedish keyboard.

Sorry.

Jesper

I have already mentioned the same problem on the German keyboard here twice. The input went only until {@@ , then the input was suddenly terminated with “}”.In the meantime I noticed that not the input with AltGr but (Alt+Ctrl+7)="{"… and (Alt+Strg+0)="}" leads to success. End well or not ???
Eggi

The Shortcuts bring no result, sorry.