Flatten Audio changes length


Probably a clear case of user error… I have a bassline (12 bars, 105 bpm), recorded in this project, that sounds much better if I apply a 50% swing (16th) to it via the musical mode in the audio editor. The editor shows also 12 bars, zero beats (?), and 105 bpm.

However, as soon as I flatten this audio file, it is a bit shorter and with this gets obviously out of time. The editor shows now 10 bars and 90 bpm. I seem not to be able to flatten it the same way I can hear it with just musical mode applied in real time. Or it somehow takes other settings into account when flattening (i.e. speeding it up). Do I need to use the bounce function instead? But then I cannot apply one of the higher quality (flatten-) algos, which probably would sound better (?).

I am sure there is something I am doing wrong - many thanks for any pointer (could not find anything related in existing posts)


stupid question or hard question? :mrgreen: