Flow Headings - alignment

If I adjust the Flow Headings template so that items are vertically aligned to the top, making other adjustments will occasionally result in them being reset back to the centre. If I save the template with elements aligned to the top. working in write mode can also result in those elements being reset back to the centre. If I then head back to the Flow Headings template, curiously, it’s says it’s aligned to the top!

All rather confusing…

There’s a long-standing bug: when you edit the content of a text frame the vertical alignment of that frame resets.

This isn’t desirable behaviour but it is expected behaviour for now, and it’s on the developers’ backlog.

Thanks Leo - appreciated.

It may be useful to know that you can drag a marquee selection around multiple text frames and set all their vertical alignment properties simultaneously.

Again, thanks - I didn’t know that, but that will be useful.

FWIW I’m currently reading up as to why I can’t move rests horizontally when I need to…

Can you give a screenshot that illustrates where you need to move rests horizontally?

Manually moving rests horizontally? Sounds dangerous. Wouldn’t you just want to use the Note Spacing tool? Rests should align to their representative rhythmic position.

Sometimes there just isn’t room for them where they ought to be positioned - for example if you have three polyphonic voices on a staff and the middle voice has a rest.

Thinking in “horrible workround mode,” you could probably create a new notehead type that looks like a rest, and then move it wherever you wanted. (But I’m not going to try that to see if it works!)

Well, maybe this isn’t the right thread to talk about this, but… moving rests horizontally is a common practice in dense polyphonic passages (as in this Bach’s WTC Prelude excerpt).

Albert, that’s perfectly possible with the Note Spacing tool, I believe.

Sure. I’m transcribing from a old vocal score at the moment. As far as possible, I like to recreate the original layout. That includes the same number of bars per line etc. This particular problem occurs about four times in a 16 bar section.

I’ve attached three files

  1. How Dorico originally notated it (Original positioning)
  2. My attempt ot close close to how the publisher notated it (Vertically aligned)
  3. How the publisher notated it (Publisher)

I avoided Dorico’s suggestion because I need the overhead space - now all I need is to nudge them over a fraction to the right and we’re done.

Vertically Aligned.png
Original positioning.png

Ah! I’m not in front of Dorico right now but the Note Spacing tool should work here. If, on clicking the square above the note, that you don’t have a circular handle for the rest, then my instinct is that you need to leave Note Spacing, select the rest(s) and (still in Engrave mode) use the Booce Column Index property. [What an awful sentence. Sorry!]
Set the Voice Column to “1” for the rests, where the default is hopefully “0”, and then have another go with the Note Spacing Tool.

Thanks Leo, I’ll try that out… Note spacing is new territory for me, I work almost exclusively with Cmd-8 (the bottom editor, if it’s OK to call it that…)

Pianoleo, I think you cannot change the Voice Column Index property of a rest—at least I don’t find it…
As a workaround you could hide the rest setting its color opacity to 0% and adding the propper glyph using Shift+X, then placing it where you want.

Albert’s correct. D’oh. Rob might be on the right lines, though.

Thanks again Leo - that works (and gave me a useful education into Note Spacing at the same time). I couldn’t find theVoice Column Index property for rests but I changed the property for the notes, thus separating them. Bit of a faff to achieve it but my fault entirely for wanting it to be like the original!

I don’t think I’d be happy with the top and bottom staves not aligning vertically.

That's it!.png

Bingo! Is that just Note Spacing?

It occurred to me that a possible workaround would be to hide the voice 1 upstem rest and insert an explicit (forced) Voice 2 upstem rest, actually rhythmically located just after the first beat of the bar (on the second demisemiquaver/32nd of the beat). If you set that to start and end voice immediately, you’d have a viable workaround, I think.

This is with a new notehead set using an 8th rest as the notehead.

You have to hide the leger lines for the “rest” and nudge it a bit to the right to avoid the leger lines for the main notes.
8th rest notehead.png