Flow title question

Using Dorico Elements. I was able to title my Flows numerically when they are allowed on the same page. However, I must have changed some sort of setting because now when I switch from “start flows on new page” to “allow on same page” I lose the title of the flows after flow 1. See attached screenshots. One shows each short flow with a number above it. The next one shows 3 short flows, but only the first one is numbered. When I leave the flows on separate pages, the title is visible.

I’ve checked the flow settings in each project and they appear to be the same. Any suggestions?


Can you post the project here? It’s often difficult to troubleshoot without seeing the file.

Wyatt 5:20:21.dorico (489.5 KB)
Thanks for your response Dan. I think I’ve uploaded the file here, but not sure I did it correctly.

It will be the settings for which Master Page to use for new Flows on new pages, in Layout Options.

1 Like

You made page overrides on all three pages. The is a big problem IIRC in Elements, since you have no way to remove them. I am sending you back your file with the page overrides removed. If you want to change flow titles, you should do it in the File > Project Info menu item.

Wyatt 5 20 21withoutOverrides.dorico (488.9 KB)

1 Like

Thanks Derek, I’m not sure how I did that or quite what you mean. I’m pretty new to Dorico. I’m using a trial version. I appreciate you correcting it for me.

Am I overiding when I click on the flow titles and type in a new title on the page itself? When I click on the title it shows what looks to be code perhaps (something like {@title@})? Is that where I’m messing up?

Precisely. It’s difficult to get the concept in Elements, but here’s a picture of what’s actually going on behind the scenes. You shouldn’t type directly into anything that’s in a green frame, because it’ll create an override. Instead, go File > Project Info, and type the title in there (you’ll need to have “Project” selected on the left hand side of that dialog first). The placeholder text - {@projectTitle@} - is a token that tells Dorico to automatically substitute whatever you’ve written in the Project Info Title field. Same goes for composer, lyricist (if there is one) and copyright (if there is one).

As for the Flow Heading - which is the frame that says “1. Flow 1”, if you want to turn that off, you can do that from within Layout Options > Page Setup > Flows > Show Flow Headings (never), and if you want to keep it but edit the “Flow 1” to something else, again, this is best achieved in Project Info.

1 Like

Thanks so much pianoleo. I know enough to know that was some kind of code, but not enough to know what I was doing! I do want to name the flows, but when I select “flow” in the dialogue box within Project Info, type a new name and then click apply, it still says “1.Flow 1” etc. I did find that I could get rid of the “1.Flow 1” by selecting the specific “flow box” below the score in setup and deleting the Flow 1, flow 2 etc. But I’m not sure why it will not work for me in Project info.

I’m essentially just writing some little phrases for a student and just want the numbers to reference each phrase.

Hmm. If I type into Project Info in the file that Derrek uploaded, it works absolutely fine.
Is it possible that along the way you’ve created more overrides for yourself? For clarity: when you create an override, Dorico locks down the text frames (the green ones indicated above) for manual editing only. It basically unlinks a load of stuff that should ideally remain linked.

The good news is that in Elements there’s not much you can do that is specific to a layout. I suspect that the quickest way for you to rescue the file itself would be to fire up Layout Options, select whichever layout you’re currently working in in the right side of the dialog, then at the bottom left switch the Part/Score dropdown to whatever type of layout you’re using, then click Save As Default. Then Close Layout Options.

Now, in Setup mode, bottom of the right panel, create a new layout (of whatever kind you’ve been working in) - probably a Full Score. Now select and delete the old Full Score layout (which will be at the top of the right panel of Setup mode) and start working with the new Full Score Layout, which will have all the same Layout Options as your previous layout but with none of the overrides.

Thanks again pianoleo. I’m actually working in a new project. I figured starting from a blank slate might be better:) And I was able to accomplish what I was looking to do, though not in the way you suggested. But it seems like I should be able to rename flows within Project Info. Perhaps the issue is that I’m leaving the flow title blank in Project Info and just using the default numbering. I don’t think I have access to some of the things you are describing because I’m using Elements. As you said, the layout options in Elements are limited, so I’ve never actually seen any text frames in green. I don’t think Elements has that level of control for layout.

Maybe I’ll go back and look at some of the SE tutorials since I think that is closer to elements than the full Dorico.

Again, thanks for your help!

The green/blue thing was to illustrate the point. The same underlying architecture powers all three versions of Dorico, so while you don’t have access to the mode that exposes those green and blue frames, there’s still a division between the types of text you should edit in Write mode (basically anything attached to music, so anything within the green frames) and the types of text you should edit in Project Info (which is titles, composers, copyrights etc.).

You certainly can rename flows in Project Info. I wonder if perhaps you’ve broken the link (this one’s fine to break) between the Flow Name (which is shown in the bottom of Setup mode, or in the left side of Project Info and the Flow Title (which is shown in the right of Project Info and at the top of each flow on the page). The only thing that matters on the page is the Flow Title. By default it’s the same as the Flow Name, but if you overwrite the title on the right side of Project Info it’ll break the link between Name and Title. I’m not sure how better to explain this one - a one-way street, perhaps?

What you are running up against here is that the default Flow Master Page insert uses the formula FlowNumber. FlowTitle, and Elements has no control over the tools needed to remove that initial flow number. I didn’t say anything before since your example just numbered your original flows 1, 2, 3 so I just left the flow name blank in Project Info to give you what you had. Otherwise I could have removed the FlowNumber token for you when I sent your file back.

Good luck with your project. I hope one day you will be able to swing Dorico Pro; it is really amazing.


What you did was perfect and exactly what I wanted. I just want the flow number as these are just short little exercises. I wanted to leave the title blank so I just have the #. So thanks again for fixing it for me! I’m pretty early in my learning curve so I appreciate all the tips from everyone.

Now that the new First Steps guide is published, you might be interested in this page from it that delves into the frames and tokens that Dorico uses to display information by default. In Dorico Elements, your options to customize this is limited compared to Pro, as you can’t edit master pages or flow headings, but hopefully it’s still helpful so you can visualize how it works.

1 Like