Focusrite Liquid Mix

Hi all,

I appreciate the hardware I am using is somewhat old school, but I have an issue with the Focusrite Liquid Mix and Cubase Pro 8.

On OSX 10.8, the plugin windows for Liquid Mix instances are blank after the installing C8. The hardware is still sonically processing the audio, but I use the hardware to follow what plugin I have selected. There is issue with C6.5 on the same system.

This happened in Windows when I first installed C8, but reinstalling the Liquid software fixed it and they work great. I have tried this on OSX and no joy.

Windows 8, Cubase 6.5 64 bit, Cubase 8 Pro 64 bit.
OSX, Cubase 6.5 32 bit, Cubase 8 Pro 64 bit.


It works fine when C8 is run in 32bit mode, but it should work fine as 64bit mode is no issue in WIndows.

Hi Rob,

I’m sorry to hear that you’re having some problems with the Liquid Mix software. Support for the software ended after OSX 10.6, please see our OS Checker:

Unfortunately, since the software was not designed with your operating system in mind, you may well encounter some issues. If possible, we would recommend reverting back to a support operating system.

If you need to contact us directly you can do so through the form on this webpage:

Best regards,
Jack // Focusrite Technical Support

Yes, there must be a lot of these units sitting on a shelf today ;-(

Maybe we got to start asking Focusrite for a update?
I’ve done it today!


Mine is eating dust (so for sale available :wink:) due to lack of legacy firewire drivers (I’ve seen a legacy driver but am concerned that the total stability will go down if I install the liquid mix with legacy firewire drivers), an update would be nice however the Original manufacturer is portugese syntfex or something like that, so will not happen I fear!

Legacy drivers for Windows 7/8/8.1?

I got it to work perfectly with Windows.

I respectfully disagree; there are no issues with the same VST plugin on older Cubase versions. The LiquidMix software works flawlessly with my Windows and OSX DAW computers; but version 8 of Cubase is the only place where issues arise.
Interestingly, version 8 on both the W8 and OSX platforms exhibit the same problem; which would further indicate it is not a LiquidMix vs. OS issue.


Wauw I got used to the idea that mine focusrite saffire pro 26 and my liquid mix where doing nothing that I forgot to checkup on drivers and solutions, thanks man! Will try this out :smiley:

I was giving out to Windows about the legacy driver issue. There were quite a few photography people doing the same, and to be very fair to Microsoft; they released the legacy driver. I was shocked! So happy that the software provider would go to that effort. Steinberg, on the other hand. I feel like such a guinea pig since getting version 8. Reminds me of the day I purchased Version 6.5 about 4 hours outside of the grace period update for V7. :unamused:

Best of luck with the Liquid Mix, it is a great unit.

EDIT: I had not realised that the old Pro 26 would have been hit by the same legacy issue. Please keep in touch as I would be more than happy to edit the website post so more people can be included. I was just focused on the Liquid Mix as I own the newer Saffires.