Fold 4 with LPK25 Mk2 problems

Hi All,
I did a search and noticed there have been issues with android 13 but i thought id mention my particular problem anyway…
Im running cubasis on the Fold 4 and although the LPK25 ‘works’ what ive noticed is it randomly drops inputs from the keyboard. So if i play a chord repeatedly, every few presses one of the notes fails to register. As i said, its completely random which note and when, but it makes playing in a take or playing just for practise pretty frustrating.
Does anyone have any ideas?
Thanks for your time.

Hi @cloudkake,

Thanks for your message and a warm welcome to the Cubasis forum!
Could the issue be related to reaching the performance limit?


Thanks Lars!
So this is on a new project straight into the piano at default when you loads up a fresh start. So I’m pretty sure there are no performace limits reached, especially with the fold 4 which is a flashship cpu with 12GB ram. It barely sweats under even the biggest audio project.

small update, ive verified the LPK25 Mk2 works just fine on PC and Mac, so i can rule out a hardware issue. Interestingly i plugged my Fold4 it into a much larger Korg MicroKontrol which draws more power, and that worked fine. I also went via a powered hub to eliminate that from the equation with the LPK25. So maybe android 13 doesnt like Akia controllers now?? Its class complient… not sure what else to try/test. Its a sham because i love this LPK25 as a travel keyboard, actually has a nice feel for such a small controller.

Ok, one more update.
I have tried another app. Just a simple midi piano app called synthasia. Now there are two options for the selected midi driver. ‘built in usb midi driver’ and Android M midi’ On the M midi option the LPK25 displays the same issues as within Cubasis, missing notes at random when pressed. However, when selecting the built in USB driver the keyboard works perfectly!
Does this shine any light on the problem? (please also see previous updates above - sorry forgot to tag you)
Many thanks.

Hi @cloudkake,

Thanks for your updated message.

Cubasis supports Android’s regular MIDI driver.

We suggest to get in touch with Akai asking them to support Android’s standard MIDI driver (MidiManager  |  Android Developers) .

Hope that helps!