"Follow Chord Track-> Scales" -Transpose is WAY off at times

I get that setting FCT to “Chords and Scales” will not transpose segments, but gives the correct color coding in VariAudio. Setting it to “Scales” will actually transpose the segments to fit the scale…

My problem is, sometimes when I set it to SCALE, my segments get thrown around by as many as 6-7 half-tones…sometimes 2-3 whole notes UP!! There seems to be no reason–a slightly out-of-tune note will get shot to a GREEN note far away, even when there is a perfectly acceptable in-tune note RIGHT next to it.

Sometimes it works perfectly, but some segments just get launched to the stratosphere. From my experience, it seems like C8 is always moving notes UP when it does this, not down.

I turned off auto-scales and set my scales in CT, if that helps.

Thanks! :slight_smile:

What is the source of the audio you are trying to change?

This is purely speculation but I wonder if it might be keying off of a harmonic and not the fundamental of the pitch. I can imagine that a fuzz guitar might pitch detect worse than a flute for example. You might play around using a copy of the audio and drastically EQing away the high end starting about a half octave above a problem notes fundamental of the note. Not musically useful but it could indicate if harmonics were playing a part.

Thanks for ur reply!

It’s vocals…lead and background.

I’ll try shelving off some of the upper EQ sometime this week. I’m trying to get used to Track Versions too. Can I “Duplicate” the version, shelve the highs, and then set “Follow Track -> Scales”? That would preserve my originals yeah?

Thanks again!

Not sure - it might end up working on the EQ’d version and then stop when you switched back. Give it a try and see. I rarely use vari-audio so…

Another approach might be to do what you are doing now, screwed up notes and all. Then once the pitches have been changed, turn off the Follow Chord Track and then manually move the offending notes to the desired pitch.