Font attributes not correct in D4

I opened one of my 3.5 “template” files and received the usual font warning dialogue about missing fonts. So, I decided to update my lyrics font to define “roman” as the proper attribute since Iowan Old Style does not have “regular” as a style. However, as I attempted to do this, I discovered that the new font editing dialogue is not properly displaying font options.

Iowan Old Style displays the following options in 3.5:

And here is the exact same dialogue in 4.0:

Interestingly, Iowan Old Style seems to be missing from font dialogs on my Mac, despite being a System font that can’t be removed. FontExplorerX says it’s activated, but it’s absent from Font Book and all dialogs/font lists.

The plot thickens. I’m currently on my m1 mini.

I realized that my lyrics weren’t displaying as Iowan even though the dialogue said so, so I changed to another font, and then tried to switch back to see if anything happened. Now I cannot see Iowan in my list either.

I’ll have to see what my old intel imac shows later.

I can take this file from D4, open it up in 3.5, change the font to Iowan, and go on my happy way. Then, if I open that same file back up in D4, the font is unavailable and substituted again. This will be a deal breaker for me until it’s fixed as Iowan is my font in hundreds of scores…

Iowan Old Style isn’t a built-in font on macOS. Could you provide me with the specific font files you’re using, James? Probably best to zip them up and email them to me. We will dispose of them after we have diagnosed the problem.

It’s in /System/Library/Fonts/Supplemental. It’s present on my Macs - M1 and Intel. FontExplorerX says it’s active, but it doesn’t appear in the font lists.

I daresay that’s significant. I have a feeling that fonts in that location are effectively invisible to Qt. I’ll ask my colleague James to take a look at the Qt code and find out.

Daniel, here’s more pertinent info:

The font is missing even from TextEdit’s font dialog.
Other fonts in that Supplemental location appear in Dorico and other apps.

I think it’s a Monterey bug.

Can it be completely a Monterey bug if the font appears in Dorico 3.5 on the same machine? Perhaps not.

What might be interesting would be running Dorico 4 in Rosetta to see whether it appears then.

Ooh. You’re right. It appears in D3.5, but it doesn’t show in Font Book or TextEdit for me.


It’s in an old .ttc TrueType font container, like a successor to the old font suitcases of yore. I wonder whether perhaps there’s something about that old format that can’t be loaded when running under ARM.

James, your best bet, I expect, is to go and find the whole family in a modern, OpenType format and switch to using that. MyFonts sells it for about £83, for example.

Weird. I just may have to do that then.

It definitely is an in-built font as all my machines have it and I’ve never purchased it. And my screen shots above were from the same (M1) machine 60 seconds apart, so it’s not an ARM thing. I have noticed that it also doesn’t show up in Pages, although it is present in every other app that I open. Que c’est bizarre…

I also tried opening via Rosetta and no dice. I wonder what has changed to cause this as it must be some difference in how the programs call for fonts. I wonder if it has anything to do with updating versions of Qt?

Same problem affects Intel Macs: but you’re right that the TTC fonts in that folder are missing from font dialogs! Eg. Super Clarendon. But the individual ttf fonts, e.g. Trattatello, are fine.

Problem is in all Apple apps.

Apple Support documents from High Sierra onwards list Iowan Old Style and some other fonts now in the Supplemental folder thus:

“These fonts are available only in documents that already use the font, or in apps that request the font by name. Some are older fonts that were included with earlier versions of the Mac operating system or Apple apps.”

Thanks for getting to the bottom of this, Ben. Very sad. I like this font, but I’m not sure I want to shuck out hundreds for it. Looks like a pivot to minion may be in order… sigh.

You could just copy it to the user Fonts folder. I’m not sure whether there will be consequences of having a duplicate of a font that kind-of-isn’t enabled anyway, though…

Interestingly, I note that from the Mojave list, several are now absent in Monterey: Bookman Old Style; Garamond (really, Garamond?), Century Schoolbook…

1 Like

There seems to be some DRM or something; I cannot copy the file out to the main fonts folder. I can copy it to an external hard drive but then when I try to install it nothing happens.

Ah: yes. It installs, but doesn’t show up. Grrr.

“Macs - they just work!”

Sorry, had to poke and derail the thread :grin: (disclaimer, mac user from their early days and still use one) Apple has never cared much about backwards compatibility.