Font bug in cubase 12

I’ve upgraded to 12 and the fonts look like this:

Mac M1, OSX 12.0.1

Same problem here! Mac mini M1, macOS Monterey!

This problem was solved by the following suggestion from Steinberg:

From your desktop, select Go>Library (Hold option to reveal hidden library folder)>Preferences>Cubase 11. Drag this folder and any previous Cubase folders to the desktop. This will reset your preferences to their default settings next time you open Cubase. If this works, you can then grab things like key commands and templates from the old preferences folder and put them in the newly created one.

I have this problem, but the solution did not work for me. I did not have Cubase 11 installed, this was a fresh install on a new machine, so there was no Cubase 11 preferences folder. 2021 M1 Max. Does anyone have any idea how to fix this?

edit
I did try deleting my Cubase 12 preferences folder and the issue persists.

image

1 Like

The folder is cubase 12! Delete that folder! Attention because you will loose all your settings and you will start cubase fresh!

Thanks @Alexandru_Stoicea . I should have explained that I tried that as well. Nothing changed.

Any updates? I encounter the same issue on M1 MBP13

Still happens to me. The error is an off by one error, where the letter drawn is the character code of the next letter. E.g. in the example above, from Scott, GY should read FX.
It then looks crazy because the width of the letters uses the width from the correct letter.

AFAIK This bug is caused by a certain plugin in Cubase. Check the search function, it popped up quite some times in the past.

Edit: There it is:

How does one identify which plugin? Regardless, it seems to be an issue with cubase as it affects all areas in the cubase GUI - eg the mixer

This issue is even more amazing since you pointed out that the text is off by one letter while still keeping their dimensions.
So in the examples given it’s “Adapt to Zoom”, “1/8” and “FX Modulator”, and not random letters, although sometimes weird characters are displayed.
What in the world :rofl:

Not really a solution, but a workaround:

This bug is caused by the Plugin “Output Arcade” in Cubase. Have you asked them about this?

Also, I think this Mac only, is that correct?

Anyway the workaround was posted here:

I think it’s Output Arcade, but how could a plugin interact with DAW text !? Just wtf.

1 Like

I have narrowed this down further. Here is how to replicate it:

On laptop retina screen, font is mangled.
Drag over to connected non-retina screen, font is fixed.

Macbook M1