Font installing problem

I am trying to install a couple new music fonts. One is Leland. With this one, I create the folder at root level in the SMUfL folder and put the metadata font in it and rename it, like the instructions say. Then, I cannot open Dorico. It gives me an error with no information, and then closes.

The other is MTF-Scorlatti. I again follow the instructions and it shows up on my MacBook, but not my iMac. Both fonts seem to be properly installed, but Leland crashes Dorico and Scorlatti just isn’t found on the iMac, but is in the font book. I am wondering if this might be a corrupted preferences file that I just need to delete. Any ideas? Thanks.


The first sounds like an error in the json file; the second sounds like the JSON file has the wrong name or file location.

The file must have the same name as the font itself, without the word ‘metadata’ or anything else; plus it must have the json file ending.

Also remember you need to restart Dorico after installing the fonts.

Thanks for the response. I think that the first case you’re right. But I’ve tried to download it several times and it happens each time. I rename it, and then Dorico won’t open. Then I change the name back and Dorico opens, but of course the font isn’t there.

The second case is more confusing to me. I have it installed, it shows in the font book, I can see it in the list if I open Word or Pages, but it doesn’t show up in Dorico. I created the MTF-Scorlatti folder and put the json file in there, Dorico opens fine, but doesn’t see the font. It’s not a huge deal, I can still do work. But I have a client who wants the look to be more like the original, which was done in Score about 30 years ago.

What I’m doing now is reinstalling the OS. I had some trouble with my iMac a month ago and it turned out that a RAM stick was bad. It may have corrupted some system files. I’ll see if that works.

Thanks again,

Update: That didn’t work. It doesn’t seem to be a system issue.


Reinstalling the OS is rarely necessary. MacOS is on a read-only volume, so can’t be changed.

Can you show the exact filepath and name of the Scorlatti json file; and upload the Leland JSON file here?

This is what it looks like on my Mac, Folder name is leland not Leland.


edit: don’t have Scorlatti

Jesele and Benwiggy,
Thanks for your help on this. I tried changing the folder and file name to leland but got the same result.Here is the Leland.json file and a screenshot of my path. (87.1 KB)

Thanks again for your assistance.


The JSON file is ‘completely wrong’. It’s the HTML of the web page on github that hosts the JSON file, not the file itself. Try this one.

For the Scorlatti file, this is what I have:


Make sure your filenames are the same. (10.1 KB)

That worked for Leland. Thanks! I have had trouble in the past trying to download certain files from Githib, so this doesn’t surprise me.

My path to the Scorlatti looks similar to yours, unless I’m missing something.?

If the font is active in the OS, but not listed in Dorico’s list of Music fonts, then that suggests there’s something wrong with the JSON file. Have you opened it in a text editor? It should have the engraving Defaults at the beginning, then the font name, version, before all the glyph data.

It’s a commercial font, so best not upload the json file here. But I do have that font, so you could PM me.

It looks like the Leland file you sent me but with different data. I’ll PM you the file (if I can figure that out!). Maybe you can see something. I haven’t worked much with JSON. Thanks, again.


I just bought it.

Try this file. (removed the file)


Font works fine here. Not sure if it’s OK to post the file here, but thought no use to people that don’t have the font. Will remove after you download it.

Well, that was worth the try, but no luck. Now I’m really confused because his other font works fine on my system. Thanks for the help. I’ll keep working on it.


So, after all the trouble yesterday with getting the Scorlatti font to work, but I tried just typing in the name of the folder again (renaming it to what it already was) and it worked after that. I had done that yesterday and it didn’t change anything, but this morning it did. I wonder if maybe it was starting from a cold boot. Thanks for the help and tolerating the problem!