Font Issues Dorico 5.1

Hi, I noticed two pretty big font issues after installing Dorico 5.1.

  1. Chords with slash bass notes such as C/G doesn’t display the slash but instead displays an empty “box”. See screenshot.

  2. Staff attached text loses it’s properties after typing it. It reverts to italic even tho I write in bold italic before closing the dialog. See screenshots.

Any ideas?

/Erik

Screenshot 2023-12-18 at 21.00.13


What font do you have chosen for Chord symbols music text in Library > Font Styles?

Hi Daniel, it’s Times New roman. Worked great in 5.0. Same with the staff attached text issue.

Well, I’m afraid that font choice wouldn’t have worked in any version of Dorico. Chord symbols music text needs to be set to Bravura Text.

Very strange. I was working in the same project right before installing 5.1 so something must’ve changed during the installation. Getting the same issues in all of my scores that were previously working.

I guess this would have a quick fix just resetting it to Bravura Text. Any ideas on the Staff Attached Text issue?

Installing a new Dorico update can categorically not have adjusted a setting in your project, I’m afraid. I’m always a bit wary of pulling the “user error” card, but I’m sorry to say I really do think that’s what has happened here.

As for your other issue, no, I don’t have any suggestions. Perhaps you could try reproducing that in a brand new empty project. If so, please document the specific steps you’re taking, and attach that new project here together with the steps required to reproduce the problem. Thanks!

I’m sure you’re right, just not sure how it could’ve happened to all my scores at the same time.

The staff text issue does not appear to be present in a new project but it’s there in all my other scores. If I open an old score all staff text is correct but as soon as I edit any given text it reverts back to Italic instead of Bold Italic.

Daniel, actually I did manage to reproduce it in a clean new Dorico document. If you set the Paragraph Style “Default Text” to Bold Italic of whatever font this issue occurs. I have attached the file.

Untitled Project.dorico (515.0 KB)

Hello,

I actually have the same problem with staff text. I guess a workaround would be to select “bold” instead of “bold italic” in the paragraph style and then change the text manually to bold italic, but trying to type as “bold italic” without doing this first just resets the text to being just “italic”. Thank you!

2 Likes

I can reproduce the problem now, thanks. We’ll have to take a deeper look at our end.

4 Likes

Thank you!

Is this related to my thread here? Missing Fonts dialog: translation issue? - #3 by Estigy

No, it’s not, I’m afraid.

1 Like