Force Duration + change tie style bug

The marked note was input using force duration (otherwise it would register as an 8th connected to two quarter notes). So far so good:

The problem happens when I want to change the tie style to dashed.

I select the tie, go to the properties menu -> “Ties” section ->turn on “Style” and choose “Dashed”:

As you can see, the ties did change into dashed, but the note that had its duration forced to be a dotted quarter no broke back to its original version.
Also because it reverted to its original duration, the newly formed tie between it and the next note has the default style selected and not the dashed style.

Another bug that occurs is that sometimes not the entire tie changes to the selected style as seen in the image below.
Notice the selected Tie Style:

Here is the file I’m using. See if you can get all the ties in the suspended cymbal to be dashed, and for the durations to remain unaltered. I can only achieve one or the other…

https://drive.google.com/open?id=1SIBcyX1j43SeADBh99h5XLBYggl9xJCn

I can confirm Michael’s bug here. I see what he sees.
Michael, have you considered using dashed slurs rather than dashed ties?

I have not…

As discussed in another thread, you have to make sure that you input the entire tie chain with Force Duration switched on: if only part of the tie chain has Force Duration set, then Dorico will feel free to renotate the notes when you make some changes.

The issue where the tie style does not change for all of the ties in the chain in Write mode is on our list to be addressed: for now, you should find that selecting the ties in Engrave mode allows you to change them all en masse.

I encountered a similar problem and the solution for me was - at least in version 1.2, I have not retried it in 2.0 - to start the tie connection from the very left note to the right. If I did it in the reverse order, from last to first, I experienced the same as you. I had Force Duration always enabled.

Michael, I figured out how to do this at the moment.

***First, I believe that at some point, the first measure of the long tied note lost the forced durations, and that is why they kept changing, so…… steps 1 through 3 will ensure the forced durations hold. (N.B. It would be helpful if Dorico gave an indication of notes that have Forced Duration applied.)

  1. In Write Mode, measure 2, select the tied note, Type u (to cut the tie)
  2. Type o (to turn on Force Duration), click on the dotted quarter note, type 6. (6 period)
  3. Right arrow (selects the quarter note) type 6

Now to get all the ties dashed without changes to the notated rhythms:

  1. Select all notes to be tied and type t
  2. In Properties under Ties, turn on Style and select Dashed (only the 1st tie gets the dashed property, which is unexpected/undesirable)
  3. Go to Engrave Mode, deselect the tied note
  4. Click on the 2nd (solid) tie chain and change the Style to Dashed
  5. Repeat #7 for the remaining ties.

You would need to do this both to Full Score and the Part.

I hope this helps! :slight_smile: