Force duration not working properly

I’ve just updated to Dorico 2.2, which from the youtube videos seemed to be a huge leap of improvement.
But what in the world happened to the “force duration”-mode (Perhaps I’m missing something or it’s a bug)?
In 2.1 you could switch force duration on and it stayed switched on as long as you wanted it to. But now
it switches off when you mouse-click somewhere else and you always have to actively switch it on again.
And it’s only available in “caret”-mode… This can’t be right, can it? That’d be horrible, as it almost doubles my work.

I just want it to stay activated. Is this possibly somehow? Thanks in advance. Oliver

That’s not correct. You can switch it on any time you have a note selected, and it will apply to that note.

Leaving it switched on “permanently” is defeating the way Dorico is intended to work.

For the type of music I do, which is editions of early music, it’s very important that the exact note values I type get displayed, even if they are inconsistent.
Dorico doesn’t always detect syncopated rhythms, for example.
I generally want to leave Force Duration on to ensure that nothing changes.

1 Like

In previous versions of Dorico, Force Duration could only be used in note input mode. If you engaged Force Duration and then left input mode, Force Duration remained switched on - there was no reason for it not to.

In Dorico 2.2 Force Duration has been tweaked in such a way that it can be applied retrospectively. If you’ve turned on Force Duration and leave input mode, the clamp icon becomes deselected. If you then click on a note, the clamp icon will light up if that note has Force Duration applied to it, but not if it doesn’t have Force Duration applied to it. This is consistent with the accent icon, or the staccato icon: if you click an accented note you’ll see the accent icon light up in the left panel. If you select an unaccented note the icon won’t light up, but you can click it (the accent icon) to both light up the icon and apply an accent to the note.

Hopefully this explains why Force Duration can now NOT be left on when you leave input mode: leaving it on would mean that if you clicked any note, it would immediately have Force Duration retrospectively applied to it.

This isn’t a bug; this is by design. Hopefully it’ll save you time rather than “double your work”.

Don’t get me wrong. I really love Dorico and I stopped working with Sibelius and Finale completely.

But I really don’t need (or want) any suggestions at all on how to handle rhythmics. I just want to write down what I have in mind or what the hand-written score in front of me says. And that is quite often not what Dorico suggests. So, till today, I used to leave force duration switched on permanently and that worked fine. But that’s over now, I think.

Imho the standard setting should be that Dorico does what I choose. If I want it to show a dotted quarter, then it shoulb be so… in any time signature… at any position within the bar… always. Without further tweaking.

Hope there is not the last word spoken.

1 Like

Thank you! The same with me.

But now Dorico is defeating the way I am intended to work.

At least it’s consistent: you know that Force Duration will always be turned off when you begin Note input. You could train yourself to hit NO to begin input (or Enter O), rather than just N or Enter.

Yes, that’s what I’ll have to do. But it really feels like having a decision made and having to defend it over and over again.

I’d forgotten (or overlooked) this change. However, the only bit of ‘fighting’ that I have with Dorico is in trying to split notes that it wants to join and tie notes that it wants to join.
If my Notation settings got changed, for any reason, I wouldn’t want the previously correct but un-Forced notes to change either. If I export a Flow from one document to another, this is a risk.

Hang on, I’ve just given this a try: How is Force Duration ‘retrospective’? If I click on a tied note, it doesn’t join it when I hit O.

No, and nor should it. It locks the positions as they are, meaning that if you shorten or extend the note the existing divisions remain in place.

From the version history:

Try clicking on the tied note, hitting O, then untie it (with U), then change it to what you want - dotted note, etc.

After that, Force Duration should act like a toggle: when it’s off it notates according to its default rules (which you can change in Notation Options); and when it’s on, it will notate it how you forced it to.

But you can press U to remove the tie, then change the length of the first note with forced duration, without re-entering the note.

It can’t “automatically join it” because that might not always be what you wanted to do - maybe you wanted a tie, but in a different place (e.g. a whole note tied to quarter, not a dotted half tied to a half, in a time signature like 7/4)

So, to ensure that note values are as I originally type: I still have to keep FD on.

Yes. I maintain it’s quickest to set Notation Options to cover 95% of cases, keep an eye on what you’re inputting, and then turn on Force Duration when you spot that Dorico’s gone against what you wanted.

Your mileage may very, and all that…