Force durations not working sometimes

Hi,

I am having trouble getting Force Durations to work in some instances. Usually, it is fine but in one passage, there are long tied notes in 12/8 but it keeps changing it over to a whole note tied to an 8th (see picture). I need it to look like a dotted quarter tied to dotted half tied to 16th. It works with force durations on up until I tie it to the 16th, then it reverts back to the incorrect durations. Again, this is with Force Durations engaged.

Thanks for the help.

You need to delete the entire tied note. THEN turn on Force Duration. Then (with Force Duration turned on) type the dotted quarter, tie to a dotted half, tie to a 16th. Then you can turn off Force Duration.

This seems to be the same problem as I’m having (https://www.steinberg.net/forums/viewtopic.php?f=246&t=125946&sid=01fdbd551242876fa5cd8281ba476451).

I’ve inputted Meursiicc’s example and get the result he does whether or not I use Force Durations. I input dotted quarter, dotted half, followed by sixteenth. I select the dotted quarter and tie it to the dotted half; the note values don’t change. I extend the tie to the sixteenth and the note values change as in the example. If I enter the second sixteenth in bar 28 as an A and extend the tie, the note values in bar 27 change back to their inputted values and the 2 sixteenths become an eighth.

I don’t understand why Dorico should want to change the inputted dotted quarter, dotted half into a whole plus eighth when the tie is extended to the following sixteenth. (ie surely Force Duration should not be needed to achieve a standard result?) In any event unless I’m doing something wrong*, Force Duration does not make any difference for me to Dorico’s behaviour.

  • I don’t believe I am doing something wrong. I’ve entered all 4 notes at the same pitch with Force Durations on. If I tie the 2 sixteenth notes alone they remain sixteenth notes, just as the 2 dotted notes are unchanged when only they are tied. It’s when the 2 groups are tied that the whole/eighth notes appear and also the sixteenths change to an eighth note. (And once theyhave changed, removing the tie does not get the sixteenth notes back.)

Meursliicc, are you on MacOS or Windows? Both pianoleo and Peter McAleer (who responded to my post) use MacOS but I use Windows. It’d be really helpful if someone else who uses Windows would make the experiment to see what result they get.

I tried this (with force durations) on my Windows 10 machine and got the following, which seems to be what you asked for.


I’m not sure what other parts may be doing in these measures, but I would have expected the dotted quarter to come before the dotted half in order to show the mid-point of the measure. Still, you should be able to do what you want.

Derrek, I think you misread - he/she/they DOES want dotted quarter before dotted half. Is that feasible on Windows 10?

Just tried on a latest macOS. Unfortunately - same results.

Okay:


Here’s what I did.

  • When left to its own devices, Dorico made the error shown by the OP. (Heaven knows why.)
  • So I used a marquee to delete the whole note tied to the eighth, which left rests.
  • I selected Force Durations.
  • I then entered the dotted quarter and pressed “T” for the tie.
  • I then entered the dotted half and again pressed "T’ for the tie.
  • At this point, all the notes appeared, but the half was not tied to the sixteenth. The caret was at the sixteenth.
  • Without deleting first and without invoking Insert, I “added” the sixteenth on top of itself. The tie appeared.

I hope this description will bring you equal satisfaction with the results.

Derrek, great to know there is a solution. Any way I see it can be achieved in a quite unintuitive way. Would be nice if somebody from Dorico team could comment it. Thank you

Actually, it would be nice if the program automatically did the “right” thing, and probably someone from the Team will see this and log it for future improvement.

Derrek

Thank you so much. I can confirm this works for me. I had previously been inputting all the notes and then adding the ties. To put my mind at rest that it’s not something peculiar to my and the OP’s Windows set up could you bear to input the passage the way I did and see if you too get the whole/eighth note in bar 27 as we did? If so, it does seem this is a bug and, ideally, one would want Dorico to default to dotted quarter/dotted half without using Force Durations.

I found that as an alternative to overwriting the sixteenth note in bar 28, I could dismiss the cursor after inputting the dotted half note and then press T, but it’s probably as broad as it’s long.

I’m delighted to say that the same method solves my problem in the “Tie oddity: possible bug” post too so I’ve cross posted there.

I get some strange behavior here as well, without any use of Forced duration. Notice what happens when I input the final 16th note.

Yes, it’s the same thing. Derrek’s workaround solves the problem. Or perhaps I should say, masks it, because the oddity is that the note that has to be forced isn’t necessarily one of the ones that Dorico changes.

In your example, as a minimum, press T while still in input mode after inputting the dotted quarter, switch on force duration then input the dotted half. Either stay in input mode, press T again and then enter the sixteenth notes or, if you’ve inputted them beforehand, come out of input mode and press T while the dotted half is selected. As far as I can work out, the only note that has to be force duration is the one immediately before the barline (but this may just be the case for the examples discussed so far). You definitely have to use T in input mode after each note that is to be tied, other than possibly the forced one. To be certain, force duration and T in input mode for all the notes to be included in the tie seems to work. (Not T for the last note in the tie of course!)

I believe the odd behaviour shown by Anders in his gif is fixed in the forthcoming update; at the very least, I cannot reproduce it.

Hi Everyone, sorry for the late response. I will try Derrek’s workaround and see if that helps. I’m on Windows 10. Thanks for all the help!

Just for everyone’s information - I’m on a Mac and am experiencing no odd behavior.

Here are the steps I used to change the whole note tied to eighth note tied to 16th note to the desired note values using force duration. Remember that you do not need to delete anything, just over-write the notes with Force Duration.

On my laptop without a MIDI keyboard:

• Click on the tied note (this selects the entire tied note, no need to use marquee)
• Type the letter O (to turn on Force Duration)
• Push Enter (to get into Note entry mode at the desired position)
• Type 6 and period (for dotted quarter note)
• Type Shift-option A (writes dotted quarter A at correct octave)
T (to tie)
• Type 7 and period (for dotted half note)
A (writes dotted half note A)
T (to tie)
• Type 4 (for sixteenth note)
A (writes 16th note A)
• Type the letter O (to turn off Force Duration)
• Escape Key (to end editing session)

Derrek,

Your solution worked for me in all instances. Thanks again!