Forcing a rest dorico doesn't like

A new user of Dorico 3.5 so please excuse basic query. My preference for notating beats 3 and 4 of the example is to use a quaver rest then crotchet, then semiquaver rest and the semiquaver note. Dorico changes this (beats 3, 4) to two quaver notes, the last tied to another quaver, then semiquaver rest and the semiquaver note. I’m unable to add a semiquaver rest after the last crotchet of the third bar. is it possible or do I have to unblock something?

You need the “Force Duration” option to override the notation Dorico is generating automatically, following the Engraving Options.

Changing the two tied quavers to a crotchet needs a little trick. If you just select the note and the force the duration, you will “lock in” the notation you already have, which is not what you want. So you have to change the duration of the note and then change it back to a crotchet.

Select the tied notes, then press O (for forced duration) 5 (to change it to a quaver followed by a rest) 6 (to change it back to a crotchet).

You could click on the icons in the left hand panel (force duration icon is the “G clamp” icon) but the keyboard shortcuts are quicker.

For the semiquaver rest, in general rests don’t actually exist as separate objects in Dorico. It generates the rests as required to fill up gaps between the notes. So I guess your problem is really that you can’t add a semiquaver note at the end of the bar.

If you want to add notes by clicking with the mouse, Dorico snaps them to a rhythmic grid. The default grid duration is a quaver, but you can change it with the menu at the bottom left corner of the screen.

A better way is use the keyboard short cuts again. Double click on the rest and you will get the orange note-entry cursor (and you will also see the rhythmic grid displayed as tick marks above the bar). Then press 4 to set the duration to a semiquaver, press space to advance the cursor by a semiquaver without entering anything, then A-G to enter the note you want.

If you really want two semiquaver rests at the end of the bar for some reason, you can use force duration again. Select the quaver rest, press O for force duration and 4 for a semiquaver. That will create a forced duration semiquaver rest, and Dorico will then fill up the bar with another semiquaver rest.

Thanks Rob, that worked as seen on the new attachment. Having achieved that notation, I used the quick solution for the remaining 8 bars which was to copy it and then paste it into them which was fine. But when I needed to change the pitch of my rhythmically corrected notes I found problems with changing their pitch, solutions not easily found in the manual. Intuitively, for example I clicked on the second voice note expecting to be able to change the pitch by playing it, but not possible. Does this mean I have to get into voice two mode again for that simple change? I presume there is a device in Dorico that allows one to click-or highlight a note and change it with the keyboard. But I couldn’t find that under Notes in the manual. Can you please direct me to those sections describing the simplest method for that please?

You can change the pitch of notes outside of note input using the Alt-Up/Down arrow (or Shift-Alt-Up/Down arrow for semitones), or you can transpose them using a popover or using the Transpose dialog (which I would say is probably more useful for larger selections).

You might prefer the ability to repitch notes using Lock Duration - allowing you to step through notes, leaving the rhythm the same but altering the pitches.

Thanks Lillie; I think the last option feels safer to me and worked OK. But it produced another problem related to the second voice notes as seen in bars 6 and 7.A rest appeared above the treble staff in bar 6 -why?-and the (second voice minims) B and C appeared in bar 7 . Not easy to correct.

Turn on View—Voice Colors. You’ll see that the notes in bar 6 are in downstem voice 1. Select everything in that bar (in that staff), and right click—Voices—set as upstem voice 1.

Once you’ve done that, select (Ctrl-click) those two half notes, cut, and paste into bar 6.

Thanks Dan, sort of worked-that is I added the second voice notes OK and corrected the stems (up voice 1, down voice 2 of course). However I noticed that although I just selected that one bar and changed voice properties, it became ‘global’ and changed all bars? So two things for me to correct now.

  1. The voice 2 notes are not correctly aligned now and the manual doesn’t tell me how to change that, and 2. I still can’t remove those unwanted rests above treble clef of bar 6 or above the bass clef in bar 7. I tried selecting them and delete but that doesn’t work. Any help appreciated.

You can use Edit > Remove Rests, but the fact that your upstem and downstem notes don’t align indicate that you’re not using voices efficiently. In Dorico, voices are numbered separately: If you’re only using two voices (one upstem, one downstem), they should be Up-stem Voice 1 and Down-stem Voice 1.

In cases where you need to align voices manually, you can do so using the Voice Column Index property. In this case you don’t need that.

Switch on Note and Rest Colors / Voice Colors in the View Menu (as Dan said earlier).

When you select a note, the status bar at the bottom left tells you which voice it is in.

I would guess you “corrected” the stem directions (with Flip Stem) when you should have changed the voice numbers instead.

You shouldn’t need Flip Stem for your example. To undo some of the muddle, select the whole score, right click and do Stem / Remove Forced Stem Directions. That will probably make the first bars wrong, with the top notes stem down and the bottom notes stem up.

To swap the voices, selecting the notes, right click, and do Voices / Swap Voice Contents.

The extra rests must mean something is in a third voice that you don’t want. You probably created that by accident. In note entry mode, pressing V cycles to the next existing voice, but Shift-V always creates a new voice.

If you can’t figure out how to get rid of the rests, post a screen shot with Voice Colours switched on so we can see what is going on.

Make sure when you’re changing voices that you choose Edit>Voices>Change Voice>[new voice] - this changes the voice of only the currently selected notes, and leaves all other notes in their previous voice untouched.

If you choose Edit>Voices>[voice], that changes the voice of all notes that are also in the currently selected voice. That’s useful if you’ve input everything as Up-stem voice 1, but then realise you want all of that to be Down-stem voice 1.

Although I’m new to Dorico, not new to software notation-used Finale for 30 and Sibelius for 20 years. Decided to try Dorico because of its superior engraving reputation and respect for Daniel who is the innovator in this field. Just mention that because I do look at Video tutorials and read some of the manual first before enlisting the goodwill of forum members when I need help.
For example, Rob suggested that …the extra rests must mean something is in a third voice that you don’t want. You probably created that by accident… That’s true. But I had read (under Voices, delete, p 1204) that…but you cannot manually delete voices once they
have been created. Why??
So I wondered if there was another option as opposed to say, hiding them if that’s possible?
The status bar showed that the bottom notes of the treble clef, initially voice 2 were now voice 1, thus explaining the changed stem direction. Lillie suggested using Edit>Voices>Change Voice>[new voice] which worked fine but just for single notes. Not sure what is meant by …Edit>Voices>[voice], that changes the voice of all notes that are also in the currently selected voice. … but in this case can’t do that globally because all notes are in the same voice.
Selecting (Ctrl-Shift-A ) can’t work in this case, nor Filter because all the same voice.
Because this is just a short piece, I’ll start again and hopefully have learnt much from forum members. Thanks again.

I guess the basic reason why you can’t delete voices is because that is how the software is designed. Maybe one of the development team will chip in to say why they made that decision.

Voices in Dorico are quite different from in Sibelius or Finale. In Sibelius you have a fixed number of voices per staff (4) which always “exist” in some sense of the word. They have fixed stem directions, and a set of (somewhat arbitrary) rules about collision avoidance (or not) between overlapping stems in different voices, etc.

In Dorico there is no limit to the number of voices, and voices are actually unique across all the staves of a multi-staff instrument, even though they are labelled (“up/downstem voice 1/2/3” etc) for each staff separately. Collisions are resolved based on the actual music on the staff, not by a fixed set of rules. There is no equivalent in Dorico of using voices 1 and 4 (but never using 2 and 3) in Sibelius to bypass some of the collision detection, for example. If you want to change how Dorico arranges the voices, either select the options you want in Engraving Options, or as a last resort you can assign the “voice column index” to each note in Engrave mode to specify exactly how the notes are stacked vertically.

Obviously it doesn’t make sense to “delete a voice” if there are notes or explicit rests in it. If a voice has no music in it, it is automatically removed when you close and reopen the project.

If you want to interchange the contents of two voices, select both sets of notes and do Voices / Swap Voice Contents.

For the unwanted rests, since you haven’t shown us a picture with voice colours we can’t guess why they are there, so we can’t tell you how to get rid of them! There are several possibilities, but trying to list all of them would probably just add to the confusion rather than solving the problem.

“Starting again” is quite a good learning strategy - if you aren’t sure how something works, create a new project and mess around, without the worry of trying to undo your mistakes, and then work on your real project.