Forcing bar rests to appear

If I have ‘Show bar rests in empty bars’ turned off, is there any way to force some bar rests to be seen please?

In a sketch, if I haven’t written anything for a bar or bars, I want the bar to be empty. If I’ve written a bar rest (i.e. instructed the player to be silent), I want the rest to be seen.

I don’t have Dorico Pro with me so can’t experiment but ideally would like a solution for Elements and SE as well anyway.

Try Shift-B, “rest.”

No luck I’m afraid. The bar rests still disappear when I turn off Show bar rests in empty bars.

Hmm, you’re right. I don’t know of a “proper” way to achieve this. You could accomplish it with minimal jank: select the bar rests you wish to banish to the Outer Realms, and scale them down to 1% (or change transparency to 0).

Maybe Daniel will have an idea. What I need to achieve is the effect of blank manuscript paper with only the essentials notated. Think classical sketches (there was a particular one by Mozart that I had in mind but I can’t find it at the moment) or a part for an electric bass player where only a few figures here and there will be written out. I just need a bit more control over whether or not a rest is shown.

In the meantime, you could select all of your rests destined for future music and color them any color you wish using the Properties panel to distinguish them from “silent” ones. Or, do the opposite.

There will be no future music. There’ll be empty staves with notes and rests here and there. If one were preparing an edition of the sketches for the War Requiem (http://www.warrequiem.org/composition-compositiondraft.html), one wouldn’t want Dorico putting in bar rests everywhere. In such a score one might want to be able to force one to appear though.

In some arrangements of pop music I like to keep things as empty as possible (especially if the music’s very repetitive) and only indicate what’s absolutely necessary. An empty bar means carry on playing in the same way; a bar rest means stop playing.

I’ve tried changing the properties of bar rests but there doesn’t seem to be any way of forcing Dorico to treat them any differently.

You can’t force some bar rests to show if you have them all set to be suppressed via layout options, I’m afraid.

Thanks. In the fullness of time it would be good if one could turn on and off Dorico’s assistance with rests.