Forcing enharmonic?

I’m entering the following phrase a lot:


When I get to the 3rd bar, I play an Eb on the MIDI keyboard, and Dorico duly writes an E flat. But when I play the E natural, Dorico changes the Eb to a D#. Is there any way to ‘lock’ or ‘force’ the original spelling, to pre-empt Dorico’s change?

I can ‘toggle’ the enharmonic spelling to D# and back to Eb, with Alt - =, but that’s a bit of a faff.

I could enter the second note with the QWERTY keyboard, which also seems to hold. Any more?

Here’s info about Dorico’s interpretation of accidentals when inputting via MIDI, and how to disable it.

Thanks, Lillie. Though I’m not sure I want to disable it permanently, as it is mostly useful.

But notation is all about the 5% of cases when we want something else!

If you don’t have any d sharps elsewhere, you could use the filter by pitch and respell them all at once without bothering with anything else.