Found a bug in cubase 9 pro

Please, fix a bug :

When importing one file that is 48khz to project that is set up as 44.1khz , Cubase asks to convert file and everything is fine.

However, when you select multiple 48 khz files , it does not ask you to convert, and you can really go bad here, because you won’t recognize that band you need to mix sounds that way (you never met singer before).

Steinberg, can you please fix this?
Thanks.

Hi and welcome,

Does it mean, Cubase doesn’t resample these files?

How did you import the file? Via File > Import > Audio Files? Or drag-and-drop?

What Cubase version do you use?

hello,
I use Cubase 9 pro
file-import-audio files-select one file and cubase asks for convert
same import procedure, but select multiple files, cubase don’t ask to convert.

The best thing to do is to report this to technical support through MySteinberg.

I can’t.
They will redirect me to my local dealer, and I don’t have time for that. This is faster and easier way. Steinberg guys read this, aren’t they?

It’s not guaranteed.

Well, is there any email adress for tehnical support? Directly, so I can wrote them?

Hi,

I will try to reproduce it in my system tomorrow. Then I will retort it to the internal bug taking system.

I’ll test this tomm

Hi,

I just tested it on my system. All imported files are 48kHz, and I import them to the project, which is 44.1kHz. I import it via File > Import > Audio File… Then I select all (3 in my case) files. And import.

The Import Option dial appears and I’m able to enable Convert and Copy to Project if Needed. When I do so, the files are using 44.2kHz sample rate in the project.

Could you try do the same in Safe Start Mode or trash preferences, please?

Hello Martin.Jirsak and thanks for reply,

Yes, I think I had same with convert and copy to project dialog, BUT…

Try to import just 1 one. In that case Cubase clearly tells you go to 48k to 44.1 … and in multiple files scenario, this won’t happen. That seems illogical to me, and can be easily overlooked … ?

Hi,

This is the dialog I get, while importing multiple files (see attachment, please). Do you get the same message?
Screen Shot 2017-08-21 at 19.08.35.png

Hey… Issues can be reported here. https://www.steinberg.net/forums/viewforum.php?f=253
Make sure you read this first. https://www.steinberg.net/forums/viewtopic.php?f=253&t=107133

Also you can open a ticket direct with Steinberg and they will get back to you, how quickly can depend.

Or maybe it is not a bug at all, but the user has ticked the “Please don’t ask again” box.

Hello Martin,

Yes, that is dialog that I get when selecting multiple files. But here is an image what do I get when selecting single file (I do believe you can recreate same). It clearly states - sample rate 48 to 44.
In my opinion, this same dialog SHOULD be present when selecting multiple files, too. Becase this way you can’t overlook easily sample rate mismatch.
It is illogical to have different dialogs for importing single and multiple files, isn’t it?

Thanks for helping !
Cubase 9 Bug.png

Hi,

Your are right. The dialog is different and it would make sense to use the same dialog. I agree.

But it’s not truth the files are not resampled. There is a way how to achieve it via the dialog which appears. So the only one bug is Cubase is using two dialogs instead of one, right?

Hey Martin,
Well, it is truth that you can EASILY mistake and overlook samplerate mismatch when importing multiple files , and NO WAY you can mistake when you import single file, and you would agree I believe. I did that mistake - wasn’t aware that my files are not in same sample rate as project.

So, is there any chance to fix this one? Thanks !

Hi,

Yes, you can resample any audio file directly from Pool. Just right-click to the file and select the option from the drop-down menu.

hey,
I was asking if there is a change for Steinberg guys to fix this illogical issue , I know that I can resample audio files, I am using cubase from 1997 I think :slight_smile:

You’re kinda backpaddling from “it doesn’t ask to convert audio” to “it doesn’t ask to convert audio clearly enough”.