FR: disable track versions

I never use this feature, I don’t like the drop-down box for it on the track, and I have already once accidentally created a new (empty) track version, making me wonder where for crying out loud the parts & events on the track had gone

You can just hide it by using the Setup button…

I have no idea how you could possibly have created a new TrackVersion by accident.

Whenever I’ve done something like that Mr. Jack Daniels was visiting the studio.

Thanks Raino, wasn’t aware, … which setup button though? where?

Left zone, bottom of the Inspector.

That is not what I mean. I can remove the TrackVersions menu from the inspector, but I can still create track versions using other means - most notably (and annoyingly) by accidentally clicking on black down-arrow next to the track name (just left of the small dB meter for the track), and then accidentally clicking “new version”. I can learn to be careful around this area of the GUI, but I have no need for track versions.

Yes, I confirm. Several times I’ve done the same accidentally. Thanks these was a testing&learning-9.0 projects and somehow I intuitively understood where my pants was gone. When working very fast with mouse, I just want to activate track by clicking somewhere between buttons in an empty place - I accidentally can click on the trackname’s popup button (hidden if mouse not near) and quickly release mousebutton - and the pointer points to “new version” in opened popup. But I just want to activate track. The popup button (triangle) is hidden and I don’t see where it is.
Maybe simpliest would be not to hide that triangle - Trackversion popup button?

I take that back - I have started to use track versions. Would still be nice though if all this wiggly wobbly stuff around the track name, like this Windows 3.11 button appearing when hovering over the track name, would be tidied up.

Im having the same problem. Every time i select a track i end up accidentally clicking the drop down menu for track versions
Is there a way to disable this feature?

Im using version 10 on mac

Happens to me all the time too, if track heights are low.
Trying to make a habit out of clicking on the track name instead of the blank, inviting, open space at the right…

Thought I’d chime in here. This was getting frustrating for me, but I just changed the Track Name Width in the Track Control Settings popup as @Romantique_Tp recommended. I have it set to “5” for Track Name Width. Now I have a little handle on the track that I can click on without accidentally clicking the Track Versions dropdown. Much better!