FR: Gap after repeat

Is there a setting for gap after a repeat barline? I’m not finding one in Spacing Gaps or Barlines, and Dorico is adding quite a bit of space unnecessarily. I added an En dash as text just to show the spacing discrepancy here.

All settings are factory default. The extra spacing gap throws off the visual balance quite a bit. Is there any way to change the extra gap after the start repeat barline?

repeatgap.dorico (504.6 KB)

1 Like

Just tried. It’s mostly when it’s at the start of a system. Not so much if it’s in the middle.
Can’t find any settings, sorry




In Engraving Options > Spacing Gaps, you can change the Minimum gap after barline. The default value is 3/4 space, as illustrated in the first picture. The second picture shows the difference after I changed that value to -1/2 space.

I did not investigate what would happen in subsequent bars in a longer piece of music.

1 Like

Oh, it didn’t occur to me to test a negative value there. Interesting!

I played around with this a bit more. Unfortunately the negative setting only appears to be beneficial in this specific case, where there is a repeat at the beginning of a system. Setting it to -1/2 results in this when the first note of the system has an accidental:

It also doesn’t appear like it has an effect on the additional gap after a repeat that occurs mid-system, and it places other accidentals too close to the barline.

I guess I would like to request a setting to specify the gap after a repeat barline, as there doesn’t seem to be an easy way to globally modify this.

That’s disappointing.
I suppose that the only way then would be to use Note Spacing in Engrave mode to move the note and the following barline to the left.

Note Spacing