Free Cubasis LE app for UR interfaces with iPad connectivity

Steinberg is happy to announce that today Cubasis LE, the compact version of Steinberg’s streamlined, multitouch sequencer for the iPad, has been announced and is now available as a free download in the App Store!

Users of class-compliant UR audio interfaces can unlock Cubasis LE* by connecting their UR interface via the Apple iPad Camera Connection Kit or the Lightning to USB Adapter.

With Cubasis LE you can capture your song ideas with touch-intuitive production tools, opening up a new world of possibilities for your creativity.

More information on Cubasis LE can be found here.

Best regards,
Stefan Schreiber

* UR audio interfaces supporting iPad-connectivity via CC mode (UR12, UR22mkII, UR242, UR44, UR28M and UR284).

Cubasis LE is a smaller form of Steinberg’s streamlined, multi touch sequencer for the iPad, and it’s presently accessible as a free download in the App Store!

Open Cubasis LE with your class-consistent UR sound interface to catch your tune thoughts with touch-natural generation instruments, opening up another universe of conceivable outcomes for your innovativeness.

I have a UR44 and want to use it with my IPAD Air 2 for use with Cubasis.

I am using an IPAD Air 2, model MH322LL/A, OS ver. 10.2.1 (14D27).

When I connect my UR44 with the Apple Lightning to USB adapter to the IPAD Air 2, I get the following message, as do other people: “I get the error.CANNOT USE DEVICE Steinberg UR44: The connected device is not supported.”

I have read all the fixes and tried all of them with no luck. I have done the following:

  1. I have rebooted everything and turned off and on in every possible way.
  2. I replaced the Lightning to USB adapter with one purchased from the Apple Store definitely made BY APPLE.
  3. I have tried numerous different USB cables, to connect to the Lightning to USB connector.
  4. I have tried plugging the UR44 directly into a wall socket (as someone mentioned that worked for them).
  5. I have tried shutting down the IPAD, and rebooting; and have tried turning on the UR44 first, then the IPAD, and vice versa as well as every other possible variation…
  6. My PC and MAC firmware on the UR44 is up-to-date.
  1. The IPAD Software is the most current: OS ver. 10.2.1 (14D27).
    The only other thing I have not tried but have seen online suggested is, I have not reset the IPad to Factory Settings, nor have I completely re-installed the Ipad software.

Is there anything else I can try? If not, what is my next step? Should I reset the Ipad to factory settings? What if that doesn’t work?

Please help. It seems that whenever I upgrade or buy something new from Steinberg, I am one of the select few that it doesn’t work properly in the beginning and it is quite frustrating, as I m sure you know.

Thank you,

Probably too obvious and redundant advice but just to check: You did put the UR44 in Class Compliant (CC) Mode?