Free Halion use in Logic - a thing of the past?

Since upgrading to Dorico 3, I’ve noticed the included Halion sound library is no longer available for use in Logic. It was a nice little bonus while it lasted. Not complaining, just noticing. Can anyone else confirm this?

Provided the eLicenser with your Dorico license on is available, you should find that you can use the sounds in HSSE in any host application that can load HSSE.

Actually, I cannot load Hallion in Logic either. I wanted to use Gregorian, but Logic is not detecting Hallion.

Hmm, it appears I have a valid license for Dorico Pro 3 in my elicenser. Halion HSSE works just as it should in Dorico 3 as I can tell. Perhaps this old expired Halion license on my eLicenser is causing a roadblock? (See attached screenshot) I’d like to delete it and see, but unfortunately I’m not being allowed the option. The ‘remove’ function in the action menu is greyed out for the this license, even after an attempt to ‘validate its license usage period’ in the actions menu. Seems I’m stuck with this expired, and possibly corrupted, license.

Currently, if I open HSSE as an instrument in Logic, I get a cello section – and all is fine with this sound, it plays, the key switches work, but if I try to load a different instrument from the library, I’m presented with “Loading Program Failed”. (See screen shot)

I reinstalled the HSSE factory library today. No change.


I’ll need to check this with my colleagues in Hamburg. As far as I know there’s no restriction here, but your experience says otherwise.

I’ve been in touch with our licensing team and our HALion team and they both confirm there are no restrictions on the hosts you can use HSSE in, or the hosts in which the licensed content will appear, so it should absolutely be possible to use the content included in your Dorico license in Logic and other hosts. Can I check, billscores, whether you see all of the content correctly registered in Steinberg Library Manager?

It works fine for me in Logic. I can even see the new Olympus Library!


Here’s what I see in Logic. It shows up normally in Dorico and Cubase.

Billscores, my colleague Frank in our HALion team points out that your screenshot shows you’ve loaded the Symphonic Orchestra plug-in, and not the HSSE plug-in. Try instantiating the HSSE plug-in instead: you shouldn’t ever need to use the Symphonic Orchestra plug-in these days.

Very odd. Can you find it listed under /Library/Audio/Plug-Ins/Components?

It’s a while since I’ve installed Halion or Hailon SE. Was there an option for selecting if you wanted to install the AU version during installation?

No, that folder is empty.

That’s where the Halion SE AU should be. I’ve just checked and the Halion Installer does give you the option of whether or not you’d like to install the AU version as well (the default is that you will). I can only suggest re-installing Halion SE.
Halion SE3 Installer.png
This may also help.

I downloaded the halion installer that didn’t came with Dorico and that one does indeed give the au- version as an option. I installed it, but it’s still not showing up in Logic.

Hmmm…

Have you looked at Preferences / Plug in Manager to see if there’s any reference to it there? I’d be surprised if it shows up in it - unless the AU’s are being directed to a different folder.

You can also look at your Main drive to see if a copy of the component file is there. Look for Halion Sonic SE.component. You’ll need to enable Finder to search for system files - click on the +, select others and then replicate the screen below.

If it is there, I think you should be able to point Logic’s Plug-in manager to find it. If it isn’t, and you’ve just recently installed Halion, I don’t know what’s going on …

Not sure what happened, but after it didn’t work last night no matter what I tried (and I cried myself to sleep cause of that…); this morning it showed up in Logic. Did it needed a computer restart? I never had to do that before:

Probably. Anyway, pleased to hear it’s sorted now.