Free Meter Questions and a bug

I’m working on inputting a free meter piece into Dorico based off of an existing published version. I have a few questions about doing so, and I’ve noticed some buggy behavior which I’ve posted a clip of here: https://www.dropbox.com/s/gtx0g3e97wrwm22/Video%20Mar%2007%2C%201%2011%2003%20PM.mov?dl=0

  1. As you can see in the clip, some triplets are being placed with the first note of the triplet as the last note on a stem, with the remaining two notes being cast off to the next staff. This happens while they are beamed together. I can’t imagine that this is desired behavior under any circumstance, and in any event, would like to know how I can “force” notes onto a specific staff in this case.

  2. Also, as you can see in the clip, some triplets lose their brace under certain circumstances. Not sure why this is happening – and I am able to fix it in the properties window afterward – and thought you should be aware of this.

  3. Finally, how can I hide the instrument name?

Thank you!

I’ve done a fair bit of free metered input in Dorico (plainsong music and that kind of thing), so I’ll have a crack at answering your questions.

  1. You can force a system break by going into Engrave Mode, selecting the first note of that triplet (the last note on the system) and selecting ‘Insert System Break’ from the left hand panel (shortcut Cmd-Alt-S). I assume that the casting off logic doesn’t take into account keeping the triplet together when in free-meter yet.

  2. You can hide instrument names by going into Layout Options (Cmd-Shift-L), then going to the Staves and Systems page of that dialog, which gives the options required.

Not sure about 2) - can I also chime in with a vaguely similar request, when it comes to triplet brackets/numbers? Would it be possible to set an engraving rule to request no triplet brackets whatsoever? I was inputting some Haydn and was reduced to selecting all the triplet brackets by marquee selection and then turning the property off. It would be great to be able to do this globally. (Apologies if it’s already there somewhere and I missed it!)

reg. 2) the default setting is to show the bracket only when necessary, which doesn’t seem to kick in here in all cases… the other setting is Always show the bracket, which I guess you could use here. Otherwise you can change the appearance on an individual basis using the Properties panel.

I can’t see any bugs in your video, Binyomin. When you’re in free meter, Dorico just fills up the systems as best it can, and it breaks them when they’re full, even if that’s in the middle of a tuplet. You can indeed simply insert a system break where you need to in Engrave mode.

As for the tuplets, if you always want the bracket to appear, there’s an option for this on the Tuplets page of Engraving Options (under ‘Brackets’, ‘Show tuplet brackets’). It’s correct that when a tuplet is the same length as a beamed group, and the tuplet bracket is on the same side as the beam, then the bracket is hidden by default, since this is a common convention in published music, but you can of course override this both via options and properties if need be.

Thanks, Daniel. Perhaps bug is the wrong term, but I can’t imagine that it is ever desired behavior, so let’s call it a feature request for future versions. It’d be great if Dorico would intentionally cast-off the entire triplet to the next system.

Similarly, I hadn’t known that there was a convention for when a brace should/shouldn’t be included, and it seemed random in its implementation looking at this piece. I’m learning a lot about notation conventions like that from my work with Dorico thus far. Thank you!