Free update from Cubase 5 to 5.5 not taking effect

Hi. I just got hold of a Cubase 5 copy which installed fine. The problem was when I tried to instal the corresponding updates to 5.5, and ultimately 5.5.3. Obviously I tried to run the 5.5 installer first, as suggested by the site, but as I open Cubase I see the version is pinned to plain 5. When I run the installer all I see is a load bar which fill up very quickly, almost instantly, and no further signs. Also, I rebooted and tried several times but no luck. Has some else been through the same at all? Any clues as to what might be wrong?
Thanks very much.

Maybe you can try to install 5.1.0 or 5.1.1 first, and then 5.5 (and after that 5.5.3)

Actually I cant install ANY of those previous updates since, unlike with the 5.5 installer, I get a Windows error message suggesting I might not actually have the software Im trying to update intalled at all!!!
Any clues, please!?!

Okay case solved!
Not sure what happened but I tried again this morning and it worked like a charm!