Free warp visual bug (waveforms do not represent warped audio)

Hello there,
Sometimes free warp does not work properly. It seems to only stretch the audio visually, but leaves the audio as it is.

I’ve got an example project attached, where this happened. Here is a picture where you can see the free warped audio above and the bounced/rendered version of it below.

Download link of the project: 18.33 MB file on MEGA

EDIT:

Is the audio correct on playback before the render ?

What render option did you use ?
That looks weird, the Event isn’t even aligned.

:thinking:

Nope, playback is wrong as well. It just looks “right” but what is played is the rendered different version. So it does not have to do with the render option. This happens also when you bounce the audio.

Happened again. After you see this error message, the audio underneath the waveform will get messed up.

I found a way to reproduce the issue.
Here is a Video where I first bounce out another audio before applying free warp, it just looks and sounds like the original.

If I now stretch the waveform at the end, the error message appears, and the audio is messed up, as you can see in the render/bounce as well.

EDIT: here is a project with that exact file, so if you do the same I did in the video, you should have the issue as well. Maybe you can confirm? @Louis_R :

This is not an error message, it says the real time algorithm has been disabled because the stretch is too large. In other words the Warp won’t be applied and you will only hear the original audio, even though the displayed waveform has been changed.

So the issue isn’t with rendering but with the Warp function itself, but in your example you are doing a very small stretch so there is no reason it would disable the Warp. This is the issue.

Yep, thats basically what I said.

In fact you are trying to put two markers too close to each other, that is the reason.
You are compressing the waveform so much that it won’t be able to process that part, so it disables the Warp for the entire Event. I think it’s an internal limitation and it has always been there.
To fix your “issue” you can simply untrim the right of your Event and put the rightmost marker further to the right so that the one you move won’t end that close to the other.
Problem solved :sweat_smile:

(That’s interesting I’m into metal too ! Those vocals need some more belting though :wink:)

The main problem is, that the representation of the waveform is off.
I’m somehow okay with the “limitations”, but when this happens, the audio resets to a point before warping it, but the visuals remain where they are.
This is clearly a visual bug.

I will tell that my client! :joy: :sweat_smile: