Freeze Trim is disabled (all the time)

I am trying to add an extra layer on a (eg.) sine curve with (eg.) a parabolic curve. In order to do that I need to freeze trim the (eg.) volume of the track, but the option ‘freeze trim’ is always disabled.

Can someone explain to me how to accomplish this? I know that it is feasible as explained at:

Maybe these articles are missing an important step that I forgot. If someone could elaborate, that would really help!
Thank you for your time.