Freezing layout

Sometimes I’ll have a good layout but then I move something slightly and everything after that gets altered unnecessarily. Is there a way of keeping the number of bars per system from changing? And is there a way to force a bar up to a previous system even though Dorico thinks it might be too crowded? I’ve tried using the Create System Break command and sometimes it works but sometimes Dorico just puts the measure in a system by itself instead of moving it up.
Also, occasionally Dorico leaves too much space between two notes, especially if there are lyrics attached. I can shift the lyrics so that the gap is no longer necessary but Dorico ignores this. Is there any way I can tell Dorico to respace the bar?

To lock the contents of a system, use the Lock System button in Engrave mode; similarly you can do that for a whole frame with Lock Frame.

If Dorico puts only one bar on a system after inserting a system break, it’s because it thinks the previous system is still too full already, and you’ll need to force its hand, by selecting the first note of the first bar on the previous system and the last note of the orphaned bar on the second system and choosing Make Into System.

You can’t currently edit rhythmic spacing, and this won’t be possible in the 1.0.10 update either (though you will be able to edit vertical spacing), but it’s a high priority for the next update.

When you lock a frame or a system does some little icon show up to show you’ve done this. I’d selected first and last notes on frames and systems I want locked but don’t see anything happen.

If you have View > Signposts > Frame Breaks and View > Signposts > System Breaks switched on, you should absolutely see signposts that show you the formatting has been locked.

I’m going to revive this conversation with a twist: is there any way to lock layout spacing?! I have spaced out my pages perfectly using both the make into frame/ system commands as well as manually tweaking all of my staff spacing by typing in exact values. Perhaps this is a “learn your lesson” moment for me however, I’ve since gone back to add a few small textual cues that are supposed to be nestled between a grand staff. The problem is when I go to add the text, it totally obliterates my meticulously planned spacing. The worst part is there is plenty of room for the text, but Dorico thinks it needs to add more. And so I repeat, is there a way to lock the stave spacing on a page?

Unfortunately there is not, although I think this would be a good idea, and I will talk to Andrew, our spacing guru, about what it might take to make this possible when we’re back in the office next week.

I thank you a thousand times over Daniel! That would be uh-mazing. Sadly, this same thing is happening to me again in a second piece. Whenever I tweak a hairpin decresc. and a corresponding dynamic marking in the next measure to line up, the staff spacing changes… so then I go move the other object… and it too changes the staff spacing. (The great irony, of course, is that since the objects are somewhat anchored to their associated notes, when the staff width changes due to one object, the other object moves again.) It is almost comical how difficult it is for these things to line up when they are independent objects and you are trying to force a staff spacing. I’m dealing primarily with keyboard music and one of the things that I really strive for in my scores is to find the most appropriate staff spacing and then try and keep to it at nearly all costs for each system barring some necessity like cross-stave beaming. I also try to get opposing pages to line up perfectly, hence typing in exact values. This is impossible when you are manually tweaking things and your score keeps moving around!

Sorry to bump a thread, Daniel, but is there any news on this front? I was engraving a piece just last night and it was happening again… I had spaced everything just right and wanted to inch a hairpin along just a touch and boom! staff spacing changed even though there was space for me to move the object without collision. I suppose I need to minimize some spacing settings in a menu somewhere.

In my particular case, I am doing keyboard music and often try to have very uniform spacing and only tweak certain staves (expand just a touch) when absolutely necessary, that way everything is matching up on opposing pages. I suppose I want to keep things a little tight sometimes and that Dorico’s default collision avoidance is what is forcing involuntary (from my end) spacing.

Perhaps an alternate solution to a global “freeze / lock layout” would be for Dorico’s default behavior to not [subsequently] change the spacing of any stave that has had a manual value set? In terms of design consistency, this would be in keeping with other behaviors in the program that, once manually altered, don’t change or engage default behaviors unless the manual property setting is removed.

I find the respacing of Dorico a little too aggresive sometimes, to be honest. When I have a very well created layout, it only takes a little movement of for example a hairpin for a bar to be moved to the next system. Is there a way to set some kind of limiters for this? Or another example, I adjusted a slur a little and in the previous system, a dynamic text moved up overlapping the staff. Not sure why this needs to be react like this.

The only way you can guarantee this won’t happen at the moment is by disabling the automatic adjustment of vertical spacing on the Vertical Spacing page of Layout Options (an option added in version 1.1). This means that you will need to make any adjustments to the default staff spacing by hand in the first place (so turning the option off will itself cause the gaps to revert back to their defaults), but you can also be sure that Dorico won’t then move staves and systems around on its own later on.

Thanks, Daniel. I am so used to do the respacing of staves and objects manually after spending years in Sibelius, this works better for me.

This new option is good to know! Since I end up going in and manually tweaking anyway, this will be perfect for me. Thanks!

Looking to lock bar lines for, exemple, when I use a pre determined measures per system and I want to keep all barlines visually aligned between systems. I’d like to add notes without changing barlines alignement.
I tried to lock frame, systems etc… with no luck.
24 (315 KB)

Dorico doesn’t provide any tools to do this, I’m afraid. You’ll have to manually adjust things using the note spacing tools in Engrave mode once you’ve finished inputting the music.

Hi Daniel, any update on this?

Just to be sure, are you referring to the option to “automatically avoid collisions between adjacent staves and systems”?

There is no feature to “freeze” the position of staves in a frame, no. In fact it would be quite hard to achieve because adjustments are stored as deltas on their default position rather than absolute positions from the top or bottom of the frame (which is important because it allows the layout to flex if the height of the music or indeed the height of the frame changes).

And yes, the option I’m referring to is indeed ‘Automatically resolve collisions between adjacent staves and systems’.

When I’m adding a first page at the beginning all my staff-spacing gets lost - everything. I have to do the spacing of 100 pages again because I added 1 page at the beginning, I can’t believe that.
Is there a way to avoid that please?

That sounds weird, something like this never happened to me. It feels like this would only happen, if you had a page override on each of these pages.
How did you add the first page and what should it contain (Title?)

What kind of page are you adding? If it’s a ‘prelim’ text page, then change the Master of page 1 to Blank (or some other Master that you’ve created), rather than adding a page.

Secondly: if you’re having to make lots of manual staff spacing adjustments, then there’s probably an easier way to get that done globally with Layout Options.