Freezing-midi keyboard not working for note input

Forgive me, but I have searched through the forum and found similar issues but the end results seem to post a diagnostic report. I am having a multitude of issues with Dorico 3.

  1. Freezing when I expand the project to full screen
  2. My midi keyboard will play the loaded sounds but won’t input midi (MPK 88) While trying to figure this out and to check to see if my midi keyboard was being recognized by other programs, I loaded a Cubase project. While Cubase was loading a ton of notes appeared in the Dorico project as 1 chord. I clicked back to Dorico and still, the midi keyboard wouldn’t input notes. Keyboard worked in Cubase.
  3. Pressing play starts the playback but when I press stop it continues or most things will stop playing but a couple of instruments will keep playing

I am having so many issues with Dorico it is useless to me. I hope that you can help me get this sorted.

Late 2015 iMac
4Ghz intel Core i7
Version 10.14.6 Mojave
Dorico (1.55 MB)

Some MIDI keyboards send a continuing stream of (non-note?) data which interferes with Dorico unless one can filter it out. I do not recall whether the MPK is one such keyboard.

If one uses the add-on program NotePerformer for sounds, there is usually a slight delay when stopping playback since NP reads ahead to determine how to play upcoming notes.

(Including the diagnostic report right off the bat was a smart move. Someone will doubtless come along soon who knows what to do with it.)

Maestro, 3.1 fixed a Problem with midi input. Are you using 3.0?

It sounds like you might have a MIDI feedback loop going on. Go to the Play page of Preferences and click ‘MIDI Input Devices’ and make sure that you don’t have any extra MIDI input devices enabled that you are also outputting MIDI on.

I am using 3.1

This could possibly be an issue. I believe that the keyboard does send a stream of non-data notes. I know that in Cubase the midi data meter is continuously pulsing regardless if anything is playing or being played. I find it odd that the previous versions of Dorico, Sibelius, Cubase all seem to function fine but when I updated to 3.0-3.1 this problem started. Only Dorico (both old and new versions) is problematic. I can play sounds from Dorico on the keyboard but nothing can be input from the keyboard. Thanks for the input, I will research it further.

I disabled all devices except the keyboard with no luck.

Also when I opened the file and try to maximize the window it froze. I have to wait a while, then select a menu item (file, edit, etc) THEN the window snaps into full screen.

I’ve attached a new Diagnostic zip

Thanks for your assistance.
Dorico (1.55 MB)

Are you maximising the window immediately after opening the project? If so, try waiting until the Play button is enabled and then maximising - does it then maximise straight away?

I was indeed doing just as you mentioned, trying to maximize upon opening, so I gave it a go as you suggested. The Play button never enabled. This got me thinking so I closed the program, unplugged my midi keyboard and reopened Dorico to find that it was instantly responsive. Like transferring your samples from an HD to SSD faster. So it is obviously a keyboard related issue. Thank you much to all who helped with the diagnostic of the problem. I shall replace my MPK 88 with it’s known issues to send random data issues with a keyboard that is not so problematic.

Thank you again to all.


If you want to dig a bit further to diagnose what kind of data your keyboard is generating, try downloading a tool like Protokol: It might indicate that you have some dust on one of the controller knobs or the sustain pedal, and a blast of compressed air might fix it.

Also, unrelated, but if you want your Dorico windows to be maximised by default, there’s an option in the Preferences dialog for this (I myself always have it set to maximise new windows by default).

Thank you Daniel and Paul. Your help is greatly appreciated.


The new keyboard arrived and all is working perfectly! Thank you guys for your help.

Very glad to hear it!