Frontier Alphatrack and Cubase 10.5

Hello All, any other users of the venerable Alphatrack control surface having issues with 10.5? Works perfectly in 10, but on 10.5 the main fader randomly kicks the motor in to resist moving it, the screen gets swamped with conflicting data and touching any of the knobs displays “shuttling”. I’m using windows 10 1909.

Thanks all!

Not to bum you out, but that sounds very much like the kinda behaviour my last Alphatrack started displaying before it finally kicked the bucket about 5 years ago. I’d already self-repaired it a couple of times, but once the motor-resisting-my-movements behaviour started, that was pretty much it.

You can try the hardware/fader recalibration function (can’t remember exactly what it is, but pretty sure it’s a “hold-buttons-down-while-powering-on” kinda thing?) - I seem to remember that sometimes helped.

It’s a shame they weren’t built better, because it’s really tricky finding a control surface with the Alphatrack’s specific mix of features (which really suited me perfectly). I owned a couple, and both of them eventually just became unrepairable, so it may not be entirely Cubase’s fault.

What happen to Frontier? They had a some very good products. They had understand the importances of software, no one do that today except maybe Avid.

Thanks - one glimmer of hope is that when setting Cubase to treat the Alphatrack as a Mackie controller the motor resistance seems to stop, but I have a feeling you’re right that in the end it’s probably just dying slowly…

Hi, it works perfectly in C11…with my old Alphatrack

Hey there Pablin! I just got myself Alphatrack and… are you on Mac OSX…? I have Cubase Pro 11 and does it work with Frontier’s official driver or did you purchase the 3rd party Synclavier updated driver to make it work on your setup…? cheers!

Hello!! no, I am on Windows 10 and I am using Frontier’s own driver. With Cubase everything works without problem. well, sometimes it doesn’t connect from scratch. what I have to do is to start the computer. disconnect and connect the Alphatrack before starting Cubase. try Frontier before buying anything … greetings!

the shuttling problems are surely due to some kind of static or bad ground connection … I have solved it with “electrical tape” or electrician’s tape, in its proper measure, covering the knobs and the fader until it goes well, and no more problems, the device is the best to use cubase if not for that silly problem …

Oh, thanks! the real problem for me is… I cannot install the driver even… on mac Mojave… it says, “there is no software to install”… lol

So… yeah… I am not on Windows unfortunately… I’ve just checked my unit on my old windows laptop though… everything works fine…

and have you tried putting only the * component * file on mac ?? I really don’t know if it is necessary to install it

I am a bit scared to do… but I am trying it now… just trying to ‘put’ component file inside the Cubase Pro 11…

(I tried installing every different version… all saying the same… failed…)

um… at last, I think I will be buying the synclavier driver…

But still though… what I do not get is,
how come every version of mac osx installation fails me, giving me this message saying,
“there is no software to install”. I have no wayaround with this message… ha

So, just moved the file, reopened Cubase 11, and nope.
Not even there is any alphatrack to add on remote control section.

I think I do need to install its driver, in order to make it work in native mode.

I think Windows does have many way arounds…

it is by copying the component file into the components folder in Cubase…I assume it is the same procedure …

Yeah, tried on Cubase 11 Pro app file on my mac… no luck haha I guess it is a bit different from Windows… lucky for you :slight_smile:

Hello, sorry. Mac doesn’t have an option to install legacy software or something? or install a driver manually like in Windows, without the need for an installer? maybe that helps and you don’t have to spend $ 35 …

You know how to install the software, and how to load the Component file, and then add it in Cubase, right?