FRontier AlphaTrack

I have recently upgraded to Cubase 6, 64 within a new, Windows 7, 64 bit computer. I Cannot get my Frontier Alphatrack controller to work. Has anybody found any tricks with this problem? If not, is the Presonus Faderport working for people with a similar system?

Hello,

did you installed the latest updates for the Alphatrack ?

http://frontierdesign.com/Products/AlphaTrack/Downloads

Cheers,

Chris

Absolutely no problems here on Cubase 6.0.4 64bit.
Did you install the 64-bit versions of the AlphaTrack control surface plug-in (AlphaTrackCN64.dll) in the Cubase 6\Components\ dir?

1 Like

You need to copy the AlphaTrack’s Cubase 64 bit plugin dll file into the Cubase Component folder as explained in the Frontier Design site (read the notes below the Cubase/Nuendo 64-bit Win Plug-in v1.0.7 option in the Frontier Design site). The rest is explained here:

http://frontierdesign.com/download/pdf/AlphaTrack/Cubase-Nuendo_AT_v1.0.4.pdf

Just make sure that you copy the 64 bit dll into the Cubase Component folder, this is important or else Cubase 6 64bit won’t recognize the AlphaTrack.

Having said that, you will see an error message when you exit Cubase. It won’t happen every time, but you will see it most of the time on exit. This is the reason why I removed the AlphaTrack from my setup and will get something else to replace it. The last driver was released in 2009, so it doesn’t seem like it is a supported item anymore (even though it is still being sold today). Just giving you a heads up.

Good luck!

Thanks guys, I’ll get to it tonight and let you know how my “luck” is :slight_smile:

I never see an error message on exit, so I think it’s setup related and not a certainty for every system.
I agree on the poor updates though.

You could be right.

All I know is that those error messages went away as soon as I disabled the AlphaTrack from Cubase, and now I don’t see them anymore on exit (the error messages came in pairs, one after the other). Something about Cubase quiting unexpectedly, giving a couple of options to choose from (i.e. wait for the program to close or force it to close). Hope this is not the case for the OP.

I also get the crash (not always) but have persisted with alphatrack as it is only on shutdown so doesn’t affect use.

I actually just checked the Frontier forum & someone posted that they thought they had fixed it…but their post cuts off mid-sentence before explaining how.
I tried posting asking him to explain but it seems every post has to be manually approved before it shows up to stop spam!

Right, it doesn’t happen all the time but it was annoying me the same, so I decided to remove it from my setup. Plus, it is an unsupported hardware considering the last time it was updated, two years ago. Either way, let us know if he tells you how to fix the issue. Thanks!

Fantastic folks. It’s working just like it used to in windows xp, 32 bit. Thank you all for your help!

I recall problems crash on exit problems in the passed when I hooked up the Alphatrack to Cubase 5, together with a Novation Nocturn and Akai MPK. Back then I resolved the problem by disabling all the MIDI outs in Cubase I did not use. In my case the only midi outputs active where the RME midi out and the Alphatrack midi out. The Akai MPK and Nocturn outputs where disabled. This solved my crash on exit back then.
Another odd thing that was very importand, was the order of installation of the USB devices. Unfortunately I can’t remember the exact installation order anymore.

Another thing I have in my current problem free setup. I don’t run the Alphatrack tray application, it isn’t needed when you use the plug-in.

Don’t know if this is of some use, but just some things you could try when experiencing problems.

Great :sunglasses:

The tray application could be the problem for me since the only MIDI outputs I had enabled were my FF400’s and the AlphaTrack, which is the same as your current setup. Question: How do you install the drivers without the tray application? I thought it was installed automatically with the drivers.

I tried setting unused midi i/o inactive & also renaming the AlphatrackApplet in system folder so the tray application doesn’t open but it’s made no difference. I still get the double crash message on exit.

This bug has been confirmed by many. Frontier have stated on their site that they have no current plans to update the driver as they are working on new projects. Very lame if you ask me. I have the crash on exit 9 times out of 10. It’s sooooo frustrating, as I love the AlphaTrack. If I unplug, the crashes disappear. Would love a fix for this.

I removed the startup parameter from the run key in the registry. You could also use msconfig to temporarily modify your startup settings.

Oh, duh!

I don’t know why I thought it would be something complicated. Thanks!

Note however that disabling the tray application made zero difference for me.

Yeah, I think I have found an AlphaTrack replacement. There’s an app called V-Control Pro for iPad that’s only $50 bucks. For the amount of control one gets, it’s actually a really good deal (granted, I need an iPad as well). Let’s see what Black Friday brings this year :wink:

There’s an app called V-Control Pro for iPad that’s only $50 bucks

I have to say that the only thing I really use on the Alphatrack is the fader. I have left hand on the fader & select channels with the right to make quick level settings & I use the flip to automate sends etc with the fader too.

I tried an android controller on my phone & it worked pretty well but I’m not convinced it’s worth spending £120 for a 7" pad (let alone the cost of an ipad).
I also have an Iiyama 23" touchscreen on my desk with the Cubase mixer always on it but neither of these are a replacement for a hardware fader for accurate setting or automating. Honestly the only thing I would find the pad apps really good for is remote control.

Closest thing to Alphatrack must be Presonus Faderport, then there’s the Steinberg CC121 (quite pricey) or maybe even the new Steinberg CMC CH (No real fader). Or coming soon for around $350 is the 8 channel iControls Pro.

I was thinking of getting an iPad anyway, so it’s not just for Cubase. But even then, I think the price point is not as bad as you think. For ~$550 USD you can get both a 16GB iPad 2 and the V-Control Pro software (it’s around $100 cheaper if you get iPad 1). You get 8 faders, send control, track readout, zoom in/out, plugin control, etc. None of the options you mentioned have all of that in one package. At least not with 8 faders at once. On top of that you also get remote control, so you’re not stuck to one setup or desk. I think this is the best choice, for me at least.

Take care!