Frustration with Chord Track, voicing and other things

So I’m a proud user of cubase since 12 years, I love it and I was very happy when the chord track fuctions was introduced

My problem is very simple,
1-I make a chord track which
2-I create different instruments playing rhythms like guitars, synth and so on, typical 1 or 2 measures
3-I duplicate these measures for the whole song
4-I select those tracks to chord track by selecting “Map to Chord track” so that I save the time needed to play all those tracks

My problem is that I get a messed up tracks when it comes to voicing, some notes are going crazy out of acceptable range, and very strange voice makes me need to do a lot of editing and waste a lot of time

When I used to use my Korg workstation the chords arranger was very smart and moves reasonable and do the voicing properly even for bass track

I’ve found that the most effective way to avoid those kinds of odd leaps and voicings is to not use the Adaptive Voicing and Automatic Scale modes.

I’ll often start with “Map to Chord Track” and then go back and adjust the chord voicing. I assigned Pads on my Control to change the voicing.

Also, after you’ve done “Map to Chord Track” go to the track’s inspect under “chords” and turn off “follow chord track.”

I agree with Stephen. While the Chord Track is great, especially at the start, to get a progression sorted out it really can’t do the heavy lifting of getting the voicing how you want.

I’ll often select the chords and drag them onto an Instrument Track. This creates a MIDI Part for each chord so I’ll glue them together into logical music sections (verse, chorus, etc.). Then fine tune the voicings in the Key or Score Editors.

The problem is that the behaviour is not consistent, some time it works sometimes not, I really wished if it can just follow exactly the same chords note and not to put some funny out of range notes

Can you be more specific about exactly how you’ve configured the Chord Track in its Inspector by posting a screen capture. Also have you tried the steps Stephen describes? Maybe post some of the inconsistent results you are getting.

I frequently use the Chord Track and while the voicings aren’t always what I’d like I’ve never had them turn out wacky like you describe, so its likely just a setting somewhere.

The Standard voicings on the InfoLine are often good enough and I don’t get any unusually spaced voicings.

Hi Raino,

Sorry for the late answer,

I’m attaching here a screen shot for my problem and the chord track settings

https://ibb.co/c4QzkR
https://ibb.co/gC65QR

Please note the the chords at measure 35, it is out of bounds for no reason, and it is not following the chord track voicing as it is intended, chord track settings are in the other picture



ru image host

In the MIDI Piano Parts how were the notes actually created?

From the Ops Manual

Converting Chord Events to MIDI
You can convert chord events to MIDI for further editing or for printing a lead sheet in the Score Editor.
PROCEDURE
1.Add an instrument track or a MIDI track.
•To add an instrument track, select Project > Add Track > Instrument.
•To add a MIDI track, select Project > Add Track > MIDI.
2.Do one of the following:
•To convert all chord events to MIDI, select Project > Chord Track > Chords to MIDI.
•To convert only selected chords to MIDI, select the chord events and drag them to the MIDI or instrument track.
RESULT
A new MIDI part is created, containing the chords as MIDI events.

If you’d have done this it would create chords of single notes on each pitch with a duration that extended until the next Chord Event. But your Piano Part has a more complicated rhythm. I’m trying to understand exactly how you got from the Chord Track to the midi notes.

Dear raino,
Thanks for all your support so far, I really appreciate it What I’m doing is very simple

1-I play a track with the chords as long notes, Like (C, F , G, C) each one is like a half or full measure, I’m using this track to define the projects chords
2-second step I select this track and create chords symbols from it, so it will be reflected in the chord track, then I’m having my chord track ready
3-I mute my chord track
3-I play a 1 measure of piano with some certain way, ballad, disco or whatever I need
4-I duplicate this measure for 20 times for example, now I have 20 measure of the same piano rythm
5-I select all those duplicated measures and do “map to chord track” then they will be changed to match my project chord track

problem that I expect they should follow exactly the same voicing I did in step 1, what happen actually is that I get notes scattered out of the bounds as you see in the picture, and I need to spend a lot of time fixing this manually by mouse

the first track i create is the one called Pad1, it is a very simple long chords and this is the one I create my chords from, please see the picture

for example for the track “piano 1” i play a simple rhythm for one measure then duplicate it many times, my ultimate goal is to not waste a lot of time playing the piano track, it just should change according to my chord track and with correct voicing exactly as it is

I reported this bug ages ago - nothing got done about it.

Found my original post with this issue (December 2016):
https://www.steinberg.net/forums/viewtopic.php?f=250&t=109612&p=608577&hilit=chord#p608577

Does that happen if you have Adaptive Voicing turned off too? It kinda looks like some kind of out of control voice leading where the nearest note in the new chord happens to be up.

Also this may or may not be the same issue the OP is having. In that example most of the voicings look reasonable but then one chord jumps way beyond where it should be only to return to normal on the next chord.

@raino, in my cases I tried both option (adaptive voicing on/off) but nothing fix this

I wish if my voice can reach the developers and have this fixed, and if anyone can help me I would be very glad