FW1884 dropped Driver with Cubase 7.5 and above

I am using a tacsam 1884. It had been working fine up to and including Cubase Pro 8. Now it doesn’t work for anything above cubase elements 7. Specifically it works with the latter but not the full versions of 5, 7.5, 8 and 8.5. It still works with pro tools 10 and Sibelius 7. I tried disabling ASIO guard but it had not effect. When I launch any of the suspect cubase versions the Fw1884 has intermittent connection , like it is flashing on and off
Any ideas?

Hi,

What OS do you use? Is the driver still compatible with your OS? I’m afraid the driver has not been updated for many years alread.

quote:
“Now it doesn’t work for anything …”
all versions work fine here on w7pro-64 / w10pro-64 (driver v1.80)
turn on the tascam 1st then boot the daw
make sure firewire drivers are set to “legacy mode”
note if win 8.1 goto…
https://support.microsoft.com/en-ca/kb/2970191/#/en-ca/kb/2970191
download the fix: 1394_OHCI_LegacyDriver.msi


cheers

The old Tascam (firmware v 1.80) is still running fine for me on Cubase 8.5.0 with Asio-guard and Win7 Pro 64. If it works for you in PT and Sibelius, then there must be some configuration issue. But I can’t imagine what would make the lights flash on and off intermittently aside from a bad FW connector.

(BTW, thanks to DLearyUS for the info and link to the legacy FW drivers for Win 8.)