FX Chain Presets Problem

Martin. This is not true. At least in my case.

  • Opened a 9.5.30 Project
  • Saved it in 9.5.40
  • Saved the Inserts as FX Chain Preset in 9.5.40
  • Removed all Inserts
  • Loaded the previously saved FX Chain Presets

In some cases it works, in some not. Thought that maybe the Kind of insert creates the Problem, but I don’t think so.

Here’s an example: I have 2 chains with 2 identical inserts. Just slight differences in parameters. One is working (00 - 01 - Drums - 04 - Snare Top - 01.fxchainpreset), one is not (00 - 01 - Drums - 05 - Snare Bottom - 01.fxchainpreset).

Any idea?
00 - 01 - Drums - 05 - Snare Bottom - 01.zip (5.67 KB)
00 - 01 - Drums - 04 - Snare Top - 01.zip (5.63 KB)

Well there is something wrong with the project im trying to copy my fx chains from. Its my old template ive grown since cubase 7 and somewhere down the line it’s become semi corrupt. In that i can’t add any channels without it crashing. But apart from that i can still mix/make music in it.

I re-saved the old template in 9.5.40, quit and reopened. Then resaved all the fxchains.

Opened the newly made template - Loaded the Drum Buss fxchain and it worked. Then after that one time none of the others load.



https://www.youtube.com/watch?v=Amw8cmp_pB4&feature=youtu.be

Good to know I’m not alone. This is seriously ridiculous.

I agree; totally ridiculous.

What’s “corrupted” about the file I posted above? A previous poster said he opened one in a text editor and replaced something with something else, but my preset doesn’t have anything like he suggested. What’s the corruption, Steinberg? Let me know and I’ll fix my old files.

the same in my case… works sometimes not always.

Hi,

If you open the files in any text editor, you will find, it’s just an XML file. In the corrupted FX Chain Preset, you will find:

<string name="Editor Name" value="&#x90;&#xa8;P"/>

In the correct preset, the same line looks like this:

<string name="Editor Name" value="editor"/>

Same with 2 other lines (wrong):

<string name="Editor Name 1" value="&#x90;&#xd4;&#xa7;P"/>
<string name="Editor Name" value="&#x99;@P"/>

correct:

<string name="Editor Name 1" value="|+K" wide="true"/>
<string name="Editor Name" value="Slot"/>

Thank you

This means we can fix it by changing some codes in the XML text?

Hi,

I haven’t tried, but I would say so.

Thanks Martin for looking into it!
I’ll give it a try.

you can delete the whole line, this worked for me on 9.5.30
and I can second the problems you have, here it still does not load (saved in .40, not loaded in .40)

Hi,

So you still get these messy names in the XML file in .40?

Here’s my drum buss that loads fine after saving in 9.5.40

https://prnt.sc/lae5nk

and here’s an example of one that doesn’t

https://prnt.sc/lae59o

Replacing the code in the XML-File did not work!

Deleting the 3 lines worked in 9.5.40 too. Thanks!

But it is really annoying and makes it hard to work with the program.
My impression is that Steinberg introduces 2 new bugs when trying to remove 1 with their updates

What lines do you delete? Does that mean you can now load the preset?

I deleted those lines

<string name="Editor Name" value="&#x90;&#xa8;P"/>



<string name="Editor Name 1" value="&#x90;&#xd4;&#xa7;P"/>
<string name="Editor Name" value="&#x99;@P"/>

Yes, I could load the preset and it worked as intended imo

I have the same issue.
Cant load my saved FX chain preset but I can load Cubases own FX chain Presets.

Was working fine in 9.5.3 but this updated messed this up and the mediabay ability to sync the audio properly to the project.

I am also having this issue. I cannot copy various Kazrog amp sims and impulse responses. Saving doesn’t seem to be an issue, but I am uncertain if the overwrite function works properly as I am unable to load anything. This doesn’t seem to be a consistent issue.

Still not working in 9.5.41 for some of the existing chains!

Did the same as I did after the 9.5.40 update as described in this post:
https://www.steinberg.net/forums/viewtopic.php?p=784289#p784289
Result: Got the same files with cryptic content for some chains which didn’t load.

Tested further and rebuilt the chain with same effects and same parameters from scratch. That worked.
Just copying the effects from an existing channel to another and save the chain again did not work.

So, a lot of work for me ahead :cry:

Hi,

As you can see in the Version History document, this had not been addressed in 9.5.41, do it’s the same as it was in C9.5.40.