FX channel don't see Group channel (Pro 9.5)


This was tested on Cubase Pro 9.5

I create Group channels Gr1, Gr2. Then I create FX channel and I can route his output to Gr1 or Gr2 channels. It’s okay.
Now I create Gr3, but FX channel created before it, doesn’t see Gr3 and I cannot select it in Route selection list. It seems that FX channel can see only groups that created before it.

Is there any logic explanation or is it a bug?

Working like it should here. Make sure that you have the correct track highlighted.

I did it in both ways
a) create group track without hilighting fx track
b) use “Add Group Channel to…” after which Routing slot is pointing to “No Bus”

I test Pro 9.0. The same!
In Elements an Artist versions (I wrote earlier) I can select FX track and Instrument track, select Q-Link and then specify route and FX track is routed to that specified target rather than it hasn’t have it in his list of available routes. Now this trick isn’t possible. Doing this I have FX tracks routet to “No Bus”.

Yes, if I create groups before fx tracks, then all is okay. But this is stupid becaus no one can foresee how much groups will have the project at the end.

Is this problem only on my computer?

Okay, I open VST Connections window and select Group/FX tab. There are all my Fx and Group channels. All Fx channels have “No Bus” and I can change it to Stereo Out only. I can any Fx channel route to another Fx channel, but Groups selection list (rightmouse popup menu) have all Groups grayed - there are all groups, but all they are disabled.

Now I create new Fx channel and it see all groups and they can be selected for routing.

So what I should do now? Create new Fx channels one for each existing channel and drag and drop all inserts from old channel to new. Then go to each track and change send to new Fx track. Is this workflow as planned? Or maybe all Cubase users are routing fx channels only to master output?

I did the same on Elements 9.0. No problems. I can hide tracks and work on groups only and route groups to another group, then unhide all tracks and they still have route to their group as it was before I hide them and change route of the groups.

Ha, ha, ha! Romantique Tp!
You know, I can write novelles-bestsellers :smiley: :smiley: :smiley:

I have checked “Connect Sends automatically for each newly created Channel” in Preferences under VST.
I uncheck this and removed all sends from group channels created automatically and now all groups are visible to any Fx channel.

Thank you for your patience :slight_smile:
Readers (newbies like me) now know about this option. At least :smiley:

Hi there. Just been reading your solution on the subject of FX routing. Thanks for posting. I have similar problem using Elements 9 in that I can’t output FX channels anywhere other than stereo out channel ( which then produces the problem of the effects sends sounding completely detached from the individual dry signal channels). I want to integrate them into the group channel. Will unchecking the auto outputs box allow me the choice of destinations for FX channel, or are there further steps to be taken? Thanks